aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-10 16:01:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-10 20:09:55 +0200
commitf8026a797c467981f9598169acc2e82ed943e7f2 (patch)
treec880a447707dfa78ea994bcbd0e1bd52484aeaca
parent2d821e4c7fd8968639bd793f5e1485447fe49374 (diff)
downloadguix-f8026a797c467981f9598169acc2e82ed943e7f2.tar
guix-f8026a797c467981f9598169acc2e82ed943e7f2.tar.gz
gnu: libsoup: Update to 2.68.2.
* gnu/packages/gnome.scm (libsoup): Update to 2.68.2. [arguments]: Update #:configure-flags. Skip tests that attempts to resolve "subdomain.localhost". [propagated-inputs]: Add GOOGLE-BROTLI and ZLIB.
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2a664e3db7..af869760fd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2690,7 +2690,7 @@ libxml to ease remote use of the RESTful API.")
(define-public libsoup
(package
(name "libsoup")
- (version "2.66.2")
+ (version "2.68.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsoup/"
@@ -2698,7 +2698,7 @@ libxml to ease remote use of the RESTful API.")
"libsoup-" version ".tar.xz"))
(sha256
(base32
- "0amfw1yvy1kjrg41rfh2vvrw5gkwnyckqbw1fab50hm6xc1acbmx"))))
+ "0crr9qprmacr626fx83cx81ggk85zsgxr4mn577kpzj6m40k1bai"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
@@ -2706,7 +2706,7 @@ libxml to ease remote use of the RESTful API.")
(guix build meson-build-system)
(ice-9 popen))
- #:configure-flags '("-Ddoc=true")
+ #:configure-flags '("-Dgtk_doc=true")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'adjust-tests
@@ -2716,6 +2716,16 @@ libxml to ease remote use of the RESTful API.")
(substitute* "tests/socket-test.c"
((".*/sockets/unconnected.*") ""))
+ ;; These fail because "subdomain.localhost" does not resolve in
+ ;; the build environment.
+ (substitute* "tests/hsts-test.c"
+ ((".*/hsts/basic.*") "")
+ ((".*/hsts/subdomains.*") "")
+ ((".*/hsts/superdomain.*") "")
+ ((".*/hsts/utf8-address.*") ""))
+ (substitute* "tests/hsts-db-test.c"
+ ((".*/hsts-db/subdomains.*") ""))
+
;; Generate a self-signed certificate that has "localhost" as its
;; 'dnsName'. Failing to do that, and starting with GnuTLS
;; 3.5.12, tests such as "ssl-tests" fail:
@@ -2784,10 +2794,12 @@ libxml to ease remote use of the RESTful API.")
("httpd" ,httpd)))
(propagated-inputs
;; libsoup-2.4.pc refers to all these.
- `(("glib" ,glib)
+ `(("brotli" ,google-brotli)
+ ("glib" ,glib)
("libpsl" ,libpsl)
("libxml2" ,libxml2)
- ("sqlite" ,sqlite)))
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
(inputs
`(("glib-networking" ,glib-networking)
("mit-krb5" ,mit-krb5)))