aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-10-10 06:44:51 +0200
committerBrian Leung <leungbk@mailfence.com>2019-10-10 06:50:29 +0200
commitc2acf8f32b6a8ed5d27416c2f4d84e830c015020 (patch)
tree0fab86315bb36d4e9f6e5f4a3d713c478f3a0571
parentaa694009c727319ae90f06bb479a35793d3d79ee (diff)
downloadguix-c2acf8f32b6a8ed5d27416c2f4d84e830c015020.tar
guix-c2acf8f32b6a8ed5d27416c2f4d84e830c015020.tar.gz
gnu: emacs-gif-screencast: Update to 1.0-2.248d1e1.
* gnu/packages/emacs-xyz.scm (emacs-gif-screencast): Update to 1.0-2.248d1e1.
-rw-r--r--gnu/packages/emacs-xyz.scm57
1 files changed, 29 insertions, 28 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fe933009f5..83820a1149 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14612,45 +14612,46 @@ try completing. See @code{fish-completion-fallback-on-bash-p}.")
(license license:gpl3+)))
(define-public emacs-gif-screencast
- (let ((commit "12b25442b97b84abae74ecb5190a9d14ff7cfe5a"))
+ (let ((commit "248d1e158405e6cba2c65ecaed40e2c59b089cd8")
+ (revision "2"))
(package
(name "emacs-gif-screencast")
- (version (git-version "20180616" "1" commit))
+ (version (git-version "1.0" revision commit))
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://gitlab.com/Ambrevar/emacs-gif-screencast/"
- "repository/archive.tar.gz?ref="
- commit))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/Ambrevar/emacs-gif-screencast.git")
+ (commit commit)))
(sha256
(base32
- "0lc457i78xjkn5idr2aaiadkh76zcsksj84z0qh80a9y775syrgh"))))
+ "19xqi5mgalnnhb4hw0fh7py2s2dllldx1xxbhwhknkdpifai8hl8"))))
(build-system emacs-build-system)
(inputs
`(("scrot" ,scrot)
("imagemagick" ,imagemagick)
("gifsicle" ,gifsicle)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((scrot (assoc-ref inputs "scrot"))
- (imagemagick (assoc-ref inputs "imagemagick"))
- (gifsicle (assoc-ref inputs "gifsicle")))
- ;; Specify the absolute file names of the various
- ;; programs so that everything works out-of-the-box.
- (emacs-substitute-variables
- "gif-screencast.el"
- ("gif-screencast-program"
- (string-append scrot "/bin/scrot"))
- ("gif-screencast-convert-program"
- (string-append imagemagick "/bin/convert"))
- ("gif-screencast-cropping-program"
- (string-append imagemagick "/bin/mogrify"))
- ("gif-screencast-optimize-program"
- (string-append gifsicle "/bin/gifsicle")))))))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((scrot (assoc-ref inputs "scrot"))
+ (imagemagick (assoc-ref inputs "imagemagick"))
+ (gifsicle (assoc-ref inputs "gifsicle")))
+ (make-file-writable "gif-screencast.el")
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (emacs-substitute-variables
+ "gif-screencast.el"
+ ("gif-screencast-program"
+ (string-append scrot "/bin/scrot"))
+ ("gif-screencast-convert-program"
+ (string-append imagemagick "/bin/convert"))
+ ("gif-screencast-cropping-program"
+ (string-append imagemagick "/bin/mogrify"))
+ ("gif-screencast-optimize-program"
+ (string-append gifsicle "/bin/gifsicle")))))))))
(home-page
"https://gitlab.com/Ambrevar/emacs-gif-screencast")
(synopsis "One-frame-per-action GIF recording")