aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-10-10 03:49:45 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-10-10 04:41:13 +0900
commit7f486d25d2a54337d4513853aade47d895e5638c (patch)
treee8828603bef1f7a9b86d91b0948c2de134ae6a11
parent081fe5ca9730822a089d8eae013025748a97e970 (diff)
downloadguix-7f486d25d2a54337d4513853aade47d895e5638c.tar
guix-7f486d25d2a54337d4513853aade47d895e5638c.tar.gz
gnu: vinagre: Fix build.
* gnu/packages/gnome.scm (vinagre): Set the '--enable-compile-warnings' configure flag to 'minimum', to prevent build failures on compilation warnings.
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index eae62a1d06..2a664e3db7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2428,7 +2428,10 @@ selection and URL hints.")))
"10jya3jyrm18nbw3v410gbkc7677bqamax44pzgd3j15randn76d"))))
(build-system glib-or-gtk-build-system)
(arguments
- '(#:phases
+ ;; Disable -Werror and such, to avoid build failures on compilation
+ ;; warnings.
+ '(#:configure-flags '("--enable-compile-warnings=minimum")
+ #:phases
(modify-phases %standard-phases
(add-before 'install 'skip-gtk-update-icon-cache
(lambda _