aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-09 19:07:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-09 19:09:42 +0200
commit636037fd0a9b3ab14a144b3eb2379cc0c59f0282 (patch)
treeb3c9602e0155f27f756171cd8d794da2f105d4ae
parente0dcd84d51cb66de545a69c82746fd261ecfedb0 (diff)
downloadguix-636037fd0a9b3ab14a144b3eb2379cc0c59f0282.tar
guix-636037fd0a9b3ab14a144b3eb2379cc0c59f0282.tar.gz
gnu: espeak: Build with the C++ 98 standard.
Fixes <https://bugs.gnu.org/37672>. Reported by Bradley Haggerty <bradigger@gmail.com>. * gnu/packages/speech.scm (espeak)[arguments]: Add CXXFLAGS to #:make-flags.
-rw-r--r--gnu/packages/speech.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 21d6027004..38ae8ae6f8 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -69,6 +69,8 @@
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib")
+ ;; The package fails to build with newer C++ standards.
+ "CXXFLAGS=-std=c++98"
"AUDIO=pulseaudio")
#:tests? #f ; no check target
#:phases