aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-07 17:06:13 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-07 17:06:13 +0200
commit4d8d2fbaf3025337f7feff627282447db82a99d5 (patch)
treea524009a7ef257b894a6de73fd1e9b340fc735fd
parente08902d3cbb307e1523485becbbdaf9aed56ac4a (diff)
parentfa984fa678f98ddc72cc89c6f6dc50ba4aff2487 (diff)
downloadguix-4d8d2fbaf3025337f7feff627282447db82a99d5.tar
guix-4d8d2fbaf3025337f7feff627282447db82a99d5.tar.gz
Merge branch 'master' into core-updates
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/audio.scm42
-rw-r--r--gnu/packages/bioconductor.scm13
-rw-r--r--gnu/packages/bioinformatics.scm13
-rw-r--r--gnu/packages/bittorrent.scm13
-rw-r--r--gnu/packages/cran.scm49
-rw-r--r--gnu/packages/emacs-xyz.scm75
-rw-r--r--gnu/packages/java.scm15
-rw-r--r--gnu/packages/linux.scm8
-rw-r--r--gnu/packages/lisp.scm178
-rw-r--r--gnu/packages/openldap.scm6
-rw-r--r--gnu/packages/patches/aria2-CVE-2019-3500.patch55
-rw-r--r--gnu/packages/statistics.scm4
13 files changed, 315 insertions, 157 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 898d22f639..39b8e009b2 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -693,7 +693,6 @@ dist_patch_DATA = \
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
%D%/packages/patches/apr-skip-getservbyname-test.patch \
- %D%/packages/patches/aria2-CVE-2019-3500.patch \
%D%/packages/patches/aspell-default-dict-dir.patch \
%D%/packages/patches/aspell-gcc-compat.patch \
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f1a45bc1ca..49ec474ffd 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1536,7 +1536,7 @@ synchronous execution of all clients, and low latency operation.")
(define-public jack-2
(package (inherit jack-1)
(name "jack2")
- (version "1.9.12")
+ (version "1.9.13")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/jackaudio/jack2/releases/"
@@ -1545,40 +1545,38 @@ synchronous execution of all clients, and low latency operation.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0crf4y9a5j9miw8r5ji4l3w5w0y2frrf7xyfsfdgacnw6vwy5vyy"))))
+ "1d1d403jn4366mqig6g8ghr8057b3rn7gs26b5p3rkal34j20qw2"))))
(build-system waf-build-system)
(arguments
- `(#:python ,python-2
- #:tests? #f ; no check target
+ `(#:tests? #f ; no check target
#:configure-flags '("--dbus"
"--alsa")
#:phases
(modify-phases %standard-phases
- (add-before
- 'configure 'set-linkflags
- (lambda _
- ;; Add $libdir to the RUNPATH of all the binaries.
- (substitute* "wscript"
- ((".*CFLAGS.*-Wall.*" m)
- (string-append m
- " conf.env.append_unique('LINKFLAGS',"
- "'-Wl,-rpath=" %output "/lib')\n")))
- #t))
+ (add-before 'configure 'set-linkflags
+ (lambda _
+ ;; Add $libdir to the RUNPATH of all the binaries.
+ (substitute* "wscript"
+ ((".*CFLAGS.*-Wall.*" m)
+ (string-append m
+ " conf.env.append_unique('LINKFLAGS',"
+ "'-Wl,-rpath=" %output "/lib')\n")))
+ #t))
(add-after 'install 'wrap-python-scripts
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Make sure 'jack_control' runs with the correct PYTHONPATH.
- (let* ((out (assoc-ref outputs "out"))
- (path (getenv "PYTHONPATH")))
- (wrap-program (string-append out "/bin/jack_control")
- `("PYTHONPATH" ":" prefix (,path))))
- #t)))))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make sure 'jack_control' runs with the correct PYTHONPATH.
+ (let* ((out (assoc-ref outputs "out"))
+ (path (getenv "PYTHONPATH")))
+ (wrap-program (string-append out "/bin/jack_control")
+ `("PYTHONPATH" ":" prefix (,path))))
+ #t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("dbus" ,dbus)
("expat" ,expat)
("libsamplerate" ,libsamplerate)
("opus" ,opus)
- ("python2-dbus" ,python2-dbus)
+ ("python-dbus" ,python-dbus)
("readline" ,readline)))
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7ca6788dd8..7b0405427c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1192,14 +1192,14 @@ the Human Protein Atlas project.")
(define-public r-regioner
(package
(name "r-regioner")
- (version "1.16.4")
+ (version "1.16.5")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "regioneR" version))
(sha256
(base32
- "0xzk057h6nkr3rvd412prxgnkpq625b90laj1kwb0i5q8j5ch760"))))
+ "12x7sh5d8y549hqz4qjb2j3ak22l79w9l0vdbv4gn0bwi5206k8h"))))
(properties `((upstream-name . "regioneR")))
(build-system r-build-system)
(propagated-inputs
@@ -5343,14 +5343,14 @@ self-organizing map clustering and minimal spanning trees.")
(define-public r-mixomics
(package
(name "r-mixomics")
- (version "6.8.4")
+ (version "6.8.5")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "mixOmics" version))
(sha256
(base32
- "0lw4c9lxcm83xrvl4y120i1z710qjbdqginhrw738azpr1f82hcg"))))
+ "0s93ai5d7li8pnxd87n12j9gypvac5zfahsk68j7zjv68dglj8s7"))))
(properties `((upstream-name . "mixOmics")))
(build-system r-build-system)
(propagated-inputs
@@ -6010,19 +6010,20 @@ arrays based on fast wavelet-based functional models.")
(define-public r-variancepartition
(package
(name "r-variancepartition")
- (version "1.14.0")
+ (version "1.14.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "variancePartition" version))
(sha256
(base32
- "1ycapwb2mq57xibrzzjz9zwxqz4nwz9f3n5gskhlr5vcs7irkjd6"))))
+ "0w4kri2389x1082xppx7l6xl1a5g74fyp02iwb4938x3gzwqwbjd"))))
(properties
`((upstream-name . "variancePartition")))
(build-system r-build-system)
(propagated-inputs
`(("r-biobase" ,r-biobase)
+ ("r-biocparallel" ,r-biocparallel)
("r-colorramps" ,r-colorramps)
("r-doparallel" ,r-doparallel)
("r-foreach" ,r-foreach)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5261e346d1..a573ef682f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7647,13 +7647,13 @@ annotation data packages using SQLite data storage.")
(define-public r-biomart
(package
(name "r-biomart")
- (version "2.40.4")
+ (version "2.40.5")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "biomaRt" version))
(sha256
(base32
- "0dj51qkxm7bh24b3bs1di7lic6zgi7g5gf9iqkqhrwkbm7sqvn0v"))))
+ "1kjvxnkpsx3j2hji3cg3ka2gv8a9mg117lzzxyqjb7qa4zw7dipx"))))
(properties
`((upstream-name . "biomaRt")))
(build-system r-build-system)
@@ -7731,13 +7731,13 @@ biological sequences or sets of sequences.")
(define-public r-rsamtools
(package
(name "r-rsamtools")
- (version "2.0.1")
+ (version "2.0.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "Rsamtools" version))
(sha256
(base32
- "0wzp5vsmqs7h44r7lcw8fnz5x9bcdcfiqq8d3h62wwibyk2lg0w1"))))
+ "188k5g40lbli7dxr96hldyvg9r9hmlbh2fp0qs5nnd12b8zbf338"))))
(properties
`((upstream-name . "Rsamtools")))
(build-system r-build-system)
@@ -9454,13 +9454,13 @@ and irregular enzymatic cleavages, mass measurement accuracy, etc.")
(define-public r-seurat
(package
(name "r-seurat")
- (version "3.1.0")
+ (version "3.1.1")
(source (origin
(method url-fetch)
(uri (cran-uri "Seurat" version))
(sha256
(base32
- "0icxndnnkkmmr9hhd01dv3w8pih7x9r0rlp3fq9pk3qajp9gmlyq"))))
+ "084lr2fjdksshsmv1ww82bgn3a9mml7kswsidjrs89snabgvn360"))))
(properties `((upstream-name . "Seurat")))
(build-system r-build-system)
(propagated-inputs
@@ -9473,6 +9473,7 @@ and irregular enzymatic cleavages, mass measurement accuracy, etc.")
("r-ggplot2" ,r-ggplot2)
("r-ggrepel" ,r-ggrepel)
("r-ggridges" ,r-ggridges)
+ ("r-httr" ,r-httr)
("r-ica" ,r-ica)
("r-igraph" ,r-igraph)
("r-irlba" ,r-irlba)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index adb377f25f..70f80398fa 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
@@ -262,16 +262,15 @@ maintained upstream.")
(define-public aria2
(package
(name "aria2")
- (version "1.34.0")
+ (version "1.35.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/tatsuhiro-t/aria2/"
- "releases/download/release-" version "/"
- name "-" version ".tar.xz"))
- (patches (search-patches "aria2-CVE-2019-3500.patch"))
+ (uri (string-append "https://github.com/aria2/aria2/releases/"
+ "download/release-" version
+ "/aria2-" version ".tar.xz"))
(sha256
(base32
- "18vpgr430vxlwbcc3598rr1srfmwypls6wp1m4wf21hncc1ahi1s"))))
+ "1zbxc517d97lb96f15xcy4l7b66grxrp3h2ids2jiwkaip87yaqy"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--enable-libaria2"
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1f35356e05..8754f83f72 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -525,31 +525,18 @@ directory.")
(define-public r-htmltools
(package
(name "r-htmltools")
- (version "0.3.6")
+ (version "0.4.0")
(source (origin
(method url-fetch)
(uri (cran-uri "htmltools" version))
(sha256
(base32
- "18k8r1s8sz1jy7dkz35n69wj20xhmllr53xmwb4pdzf2z61gpbs4"))))
+ "06l17d8jkf438yk2mchpsp4j90bynnapz3nabh5vkcc324p5a62v"))))
(build-system r-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; See https://github.com/rstudio/htmltools/pull/68
- ;; The resource files are in the store and have mode 444. After
- ;; copying the files R fails to remove them again because it doesn't
- ;; have write access to them.
- (add-after 'unpack 'copy-files-without-mode
- (lambda _
- (substitute* "R/html_dependency.R"
- (("file.copy\\(from, to, " prefix)
- (string-append prefix
- "copy.mode = FALSE, ")))
- #t)))))
(propagated-inputs
`(("r-digest" ,r-digest)
- ("r-rcpp" ,r-rcpp)))
+ ("r-rcpp" ,r-rcpp)
+ ("r-rlang" ,r-rlang)))
(home-page "https://cran.r-project.org/web/packages/htmltools")
(synopsis "R tools for HTML")
(description
@@ -559,13 +546,13 @@ directory.")
(define-public r-htmlwidgets
(package
(name "r-htmlwidgets")
- (version "1.3")
+ (version "1.5")
(source (origin
(method url-fetch)
(uri (cran-uri "htmlwidgets" version))
(sha256
(base32
- "04jsdh14l2zifbjpbbh23w7bxz1wpsas0zb2gy2zwv4yqamzzr7i"))))
+ "1h2sj5h9vcssb73nz63gmw5bajs73m9q807fsypvr621gb1s124i"))))
(build-system r-build-system)
(propagated-inputs
`(("r-htmltools" ,r-htmltools)
@@ -5339,14 +5326,14 @@ simple method for converting between file types.")
(define-public r-maptools
(package
(name "r-maptools")
- (version "0.9-5")
+ (version "0.9-8")
(source
(origin
(method url-fetch)
(uri (cran-uri "maptools" version))
(sha256
(base32
- "1pbvcn9xfx0hxq1ppbfg9xm5j04q4c15nj983yjmg7dlkzq135ax"))))
+ "1ix3cg74w0w6cj8nwi0r9n3y5q9ljc21hm8xq6yqqngs57prvn2x"))))
(build-system r-build-system)
(propagated-inputs
`(("r-foreign" ,r-foreign)
@@ -5367,14 +5354,14 @@ exchanging spatial objects with other R packages.")
(define-public r-later
(package
(name "r-later")
- (version "0.8.0")
+ (version "1.0.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "later" version))
(sha256
(base32
- "08g503xjxrfxvrzj0cavsrz4m8ykbha64344j1w2r6v17js2hakb"))))
+ "11xjavj7siz0xv2ffq1ld4bwl35jyrcfpvvs4p3ilpifxx49hyr7"))))
(build-system r-build-system)
(propagated-inputs
`(("r-bh" ,r-bh)
@@ -5390,14 +5377,14 @@ time after the current time, after the R execution stack has emptied.")
(define-public r-promises
(package
(name "r-promises")
- (version "1.0.1")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "promises" version))
(sha256
(base32
- "0n2mlv6bvfb4yhgcml696l9vkbw21pz0smqylivr606z99rwgny2"))))
+ "01l0ydjvvy6afcg5d6pzvk1ikd3djq8n2flv8c831ksn68z0zsn8"))))
(build-system r-build-system)
(propagated-inputs
`(("r-later" ,r-later)
@@ -5860,14 +5847,14 @@ results to the user.")
(define-public r-hdf5r
(package
(name "r-hdf5r")
- (version "1.2.0")
+ (version "1.3.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "hdf5r" version))
(sha256
(base32
- "10gynjwaaxks8y9c2fl8k040j0nbwn372nil70009yfk9wrkx0aq"))))
+ "1pq12vkfqxvcaznwaxvjdg3acimk5a20m8h18sixvxc34vnqxw8f"))))
(build-system r-build-system)
(inputs
`(("hdf5" ,hdf5)
@@ -8960,14 +8947,14 @@ package provides a minimal R interface by relying on the Rcpp package.")
(define-public r-rcppparallel
(package
(name "r-rcppparallel")
- (version "4.4.3")
+ (version "4.4.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "RcppParallel" version))
(sha256
(base32
- "1ym0bzs9g6bsg2lz24fisxxa3gypr6xcvrczn304czmrrag9413s"))))
+ "0p13f2mywjr7gmskf8ri4y8p5yr1bvr4xrpw2w11vdvafwz1vcia"))))
(properties `((upstream-name . "RcppParallel")))
(build-system r-build-system)
(home-page "http://rcppcore.github.io/RcppParallel")
@@ -10317,14 +10304,14 @@ and manipulating sets of ontological terms.")
(define-public r-gargle
(package
(name "r-gargle")
- (version "0.3.1")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "gargle" version))
(sha256
(base32
- "0vqgp4w03sdyj0q96gxkybqflzzbaw84zifsbi7pxk5y08fimj2v"))))
+ "08zhfk2sl342w35i5n2c93ayypg3z0kbl0020l3y9adqka1vazgx"))))
(build-system r-build-system)
(propagated-inputs
`(("r-fs" ,r-fs)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 23ec3555cf..1b9ae73966 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6621,7 +6621,7 @@ ack, ag, helm and pt.")
(define-public emacs-helm
(package
(name "emacs-helm")
- (version "3.3")
+ (version "3.5.0")
(source
(origin
(method git-fetch)
@@ -6630,7 +6630,7 @@ ack, ag, helm and pt.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0fqhw7r9fcsja5d3pgbipw7pkw9nj534faav6hi45413hc3gyv92"))))
+ (base32 "07bijcnfkv60l3swasxv53x32l6glds05mxnbb3xbnmkgm1pm9if"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-async" ,emacs-async)
@@ -6647,6 +6647,31 @@ considered to be its successor. Helm sets out to clean up the legacy code in
not tied in the trap of backward compatibility.")
(license license:gpl3+)))
+(define-public emacs-helm-org
+ (let ((commit "542dda7bc9a3b9dfb439e4f8a1e5f60cfb6cc256")
+ (revision "1"))
+ (package
+ (name "emacs-helm-org")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-org.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xa32w80icrykpyfb89fhb0s4l7ysi0sc7f7lfwqz5najwbgqipl"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (home-page "https://github.com/emacs-helm/helm-org")
+ (synopsis "Helm interface to the Silver Searcher")
+ (description
+ "This package provides a frontend for grepping tools like ag and ack,
+as well as features for editing search results.")
+ (license license:gpl3+))))
+
(define-public emacs-helm-swoop
(package
(name "emacs-helm-swoop")
@@ -6675,7 +6700,7 @@ for search-based navigation of buffers.")
(revision "1"))
(package
(name "emacs-helm-ag")
- (version "0.58")
+ (version (git-version "0.58" revision commit))
(source
(origin
(method git-fetch)
@@ -7267,7 +7292,7 @@ pasting into and from @code{tmux} paste buffers.")
(define-public emacs-evil-nerd-commenter
(package
(name "emacs-evil-nerd-commenter")
- (version "3.3.7")
+ (version "3.3.8")
(source
(origin
(method git-fetch)
@@ -7277,7 +7302,7 @@ pasting into and from @code{tmux} paste buffers.")
(file-name (git-file-name name version))
(sha256
(base32
- "1r8shfdddys9vqvrxf7s6z83ydqx9xhqs9sa7klbsajryqcp50b7"))))
+ "0qd5a89mzvdyhd8lm13iwp220vzpd6dajwx54frlc5bzsxdmg6vc"))))
(build-system emacs-build-system)
(propagated-inputs `(("emacs-evil" ,emacs-evil)))
(arguments
@@ -11690,6 +11715,26 @@ tables of contents.")
timestamps by providing a @code{ts} struct.")
(license license:gpl3+))))
+(define-public emacs-peg
+ (package
+ (name "emacs-peg")
+ (version "0.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacsmirror/peg")
+ (commit version)))
+ (sha256
+ (base32
+ "0kjz7ch4bn0m4v9zgqyqcrsasnqc5c5drv2hp22j7rnbb7ny0q3n"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacsmirror/peg/")
+ (synopsis "Parsing Expression Grammars in Elisp")
+ (description "This package provides a macro that parses the current buffer
+according to a parsing expression grammar.")
+ (license license:gpl3+)))
+
(define-public emacs-org-ql
(package
(name "emacs-org-ql")
@@ -12609,8 +12654,8 @@ key again.")
(license license:gpl3+)))
(define-public emacs-mbsync
- (let ((commit "8f80c267cab1acb0d5bdd5b0059f5d1790d499ff")
- (revision "3"))
+ (let ((commit "b62491c0e0d89eb9c66261a16d7ac81231c9c453")
+ (revision "4"))
(package
(name "emacs-mbsync")
(version (git-version "0.1.2" revision commit))
@@ -12623,7 +12668,7 @@ key again.")
(file-name (git-file-name name version))
(sha256
(base32
- "1dwlpcczsa6b7bwv5149by0qmk8v2y7bjad02k4fy25yxznqzci9"))))
+ "1zlih37mkqjn2czl12zn7lgxxljvrwhqqpbksj9c91zn0f0rm3mz"))))
(build-system emacs-build-system)
(home-page "https://github.com/dimitri/mbsync-el")
(synopsis "Interface to mbsync for Emacs")
@@ -15082,10 +15127,8 @@ accept and reject GitHub pull requests.")
(license license:gpl3+))))
(define-public emacs-deadgrep
- ;; We prefer a newer commit (four commits newer than release) because of a
- ;; bugfix for globbing.
- (let ((commit "329119c65126f7917d3910bc584f4191ba8f21ac")
- (revision "1"))
+ (let ((commit "3fc7ca1f58e190f0c80da455a0e40187e673020e")
+ (revision "2"))
(package
(name "emacs-deadgrep")
(version (git-version "0.8" revision commit))
@@ -15098,7 +15141,7 @@ accept and reject GitHub pull requests.")
(file-name (git-file-name name version))
(sha256
(base32
- "0fxf7gq9sjfkgpdfqx10w3l3nd4rwa8kv9plyxk1fqacb3s5m6ai"))))
+ "016gwqxd9aqzjw3hqv3vdf8cs6la8r65g6azg5rlmjqwfx3vsaha"))))
(build-system emacs-build-system)
(inputs
`(("emacs-dash" ,emacs-dash)
@@ -18161,8 +18204,8 @@ corresponding Evil keys.")
(license license:expat))))
(define-public emacs-evil-traces
- (let ((commit "b41b7432b8110378c199a3d25af464083777f453")
- (revision "1"))
+ (let ((commit "1931e3ea2c64b4aec393a9c25063c330deff55e3")
+ (revision "2"))
(package
(name "emacs-evil-traces")
(version (git-version "0.0.1" revision commit))
@@ -18174,7 +18217,7 @@ corresponding Evil keys.")
(file-name (git-file-name name version))
(sha256
(base32
- "0a15f2saynz9fws1h5s7py3cshsk4xs1kwgwj1m5rsin36g0j6hc"))))
+ "12p9lfxscs182vbd4dy0m5gacs3d4kyprbz5yndpwvl8g2qsqplz"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-evil" ,emacs-evil)))
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 495e6bbd3a..d9ea5526b8 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1406,12 +1406,17 @@ bootstrapping purposes.")
(add-after 'install 'install-libjvm
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((lib-path (string-append (assoc-ref outputs "out")
- "/lib/"
+ ;; See 'INSTALL_ARCH_DIR' in
+ ;; 'configure'.
,(match (%current-system)
("i686-linux"
- "i386")
+ "/lib/i386")
("x86_64-linux"
- "amd64")))))
+ "/lib/amd64")
+ ("armhf-linux"
+ "/lib/arm")
+ ("aarch64-linux"
+ "/lib/aarch64")))))
(symlink (string-append lib-path "/server/libjvm.so")
(string-append lib-path "/libjvm.so")))
#t))
@@ -1559,6 +1564,10 @@ bootstrapping purposes.")
(description
"This package provides the Java development kit OpenJDK built with the
IcedTea build harness.")
+
+ ;; 'configure' lists "mips" and "mipsel", but not "mips64el'.
+ (supported-systems (delete "mips64el-linux" %supported-systems))
+
;; IcedTea is released under the GPL2 + Classpath exception, which is the
;; same license as both GNU Classpath and OpenJDK.
(license license:gpl2+))))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e1fc4a983a..63ce0c62ae 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -183,9 +183,9 @@ defconfig. Return the appropriate make target if applicable, otherwise return
(define deblob-scripts-5.3
(linux-libre-deblob-scripts
- "5.3.1"
+ "5.3.4"
(base32 "15n09zq38d69y1wl28s3nasf3377qp2yil5b887zpqrm00dif7i4")
- (base32 "1av9ykv714cnl0clls8rhwa8rwflz6ivg17gharj1x650qp6vnw3")))
+ (base32 "0nrimraf46nf6y1hwkg29fyl0a83wnj0mwq54ggxvffn9gk5h9pa")))
(define deblob-scripts-5.2
(linux-libre-deblob-scripts
@@ -357,10 +357,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
"linux-" version ".tar.xz"))
(sha256 hash)))
-(define-public linux-libre-5.3-version "5.3.2")
+(define-public linux-libre-5.3-version "5.3.4")
(define-public linux-libre-5.3-pristine-source
(let ((version linux-libre-5.3-version)
- (hash (base32 "0szw21mpp94gp3zn2fgllbv6fdjjf20njgrcjay7vjmm7farq7rn")))
+ (hash (base32 "0vi4bgcr921z5l6fbcrcgmhaji5gl2avpmp7njna6v0f7sxism0r")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.3)))
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index ed3efc7bdb..84597e4e73 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6388,7 +6388,7 @@ the return type of a function.")
(package
(name "sbcl-optima")
(build-system asdf-build-system/sbcl)
- (version (git-version "0.1" revision commit))
+ (version (git-version "1.0" revision commit))
(home-page "https://github.com/m2ym/optima")
(source
(origin
@@ -6451,6 +6451,29 @@ quasiquote is enable matching of quasiquoted patterns, using Optima or
Trivia.")
(license license:expat)))
+(define-public cl-fare-quasiquote
+ (sbcl-package->cl-source-package sbcl-fare-quasiquote))
+
+(define-public sbcl-fare-quasiquote-optima
+ (package
+ (inherit sbcl-fare-quasiquote)
+ (name "sbcl-fare-quasiquote-optima")
+ (inputs
+ `(("optima" ,sbcl-optima)
+ ("fare-quasiquote" ,sbcl-fare-quasiquote)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-requirement
+ (lambda _
+ (substitute* "fare-quasiquote-optima.asd"
+ (("\\(:version \"optima\" \"1\\.0\"\\)")
+ "\"optima\""))
+ #t)))))))
+
+(define-public cl-fare-quasiquote-optima
+ (sbcl-package->cl-source-package sbcl-fare-quasiquote-optima))
+
(define-public sbcl-fare-quasiquote-readtable
(package
(inherit sbcl-fare-quasiquote)
@@ -6464,6 +6487,22 @@ Trivia.
This package uses fare-quasiquote with named-readtable.")))
+(define-public cl-fare-quasiquote-readtable
+ (sbcl-package->cl-source-package sbcl-fare-quasiquote-readtable))
+
+;; TODO: Add support for component-less system in asdf-build-system/sbcl.
+(define-public cl-fare-quasiquote-extras
+ (package
+ (inherit cl-fare-quasiquote)
+ (name "cl-fare-quasiquote-extras")
+ (build-system asdf-build-system/source)
+ (propagated-inputs
+ `(("fare-quasiquote" ,cl-fare-quasiquote)
+ ("fare-quasiquote-optima" ,cl-fare-quasiquote-optima)
+ ("fare-quasiquote-readtable" ,cl-fare-quasiquote-readtable)))
+ (description "This library combines @code{fare-quasiquote-readtable} and
+@code{fare-quasiquote-optima}.")))
+
(define-public sbcl-trivia.level0
(let ((commit "902e0c65602bbfe96ae82e679330b3771ddc7603")
(revision "1"))
@@ -7488,3 +7527,140 @@ of C+GObject libraries without the need of writing dedicated bindings.")
(define-public cl-gobject-introspection
(sbcl-package->cl-source-package sbcl-cl-gobject-introspection))
+
+(define-public sbcl-string-case
+ (let ((commit "718c761e33749e297cd2809c7ba3ade1985c49f7")
+ (revision "0"))
+ (package
+ (name "sbcl-string-case")
+ (version (git-version "0.0.2" revision commit))
+ (home-page "https://github.com/pkhuong/string-case")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n5i3yh0h5s636rcnwn7jwqy3rjflikra04lymimhpcshhjsk0md"))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "Efficient string= case in Common Lisp")
+ (description
+ "@code{string-case} is a Common Lisp macro that generates specialised decision
+trees to dispatch on string equality.")
+ (license license:bsd-3))))
+
+(define-public cl-string-case
+ (sbcl-package->cl-source-package sbcl-string-case))
+
+(define-public ecl-string-case
+ (sbcl-package->ecl-package sbcl-string-case))
+
+(define-public sbcl-global-vars
+ (let ((commit "c749f32c9b606a1457daa47d59630708ac0c266e")
+ (revision "0"))
+ (package
+ (name "sbcl-global-vars")
+ (version (git-version "1.0.0" revision commit))
+ (home-page "https://github.com/lmj/global-vars")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06m3xc8l3pgsapl8fvsi9wf6y46zs75cp9zn7zh6dc65v4s5wz3d"))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "Efficient global variables in Common Lisp")
+ (description
+ "In Common Lisp, a special variable that is never dynamically bound
+typically serves as a stand-in for a global variable. The @code{global-vars}
+library provides true global variables that are implemented by some compilers.
+An attempt to rebind a global variable properly results in a compiler error.
+That is, a global variable cannot be dynamically bound.
+
+Global variables therefore allow us to communicate an intended usage that
+differs from special variables. Global variables are also more efficient than
+special variables, especially in the presence of threads.")
+ (license license:expat))))
+
+(define-public cl-global-vars
+ (sbcl-package->cl-source-package sbcl-global-vars))
+
+(define-public ecl-global-vars
+ (sbcl-package->ecl-package sbcl-global-vars))
+
+(define-public sbcl-trivial-file-size
+ (let ((commit "1c1d672a01a446ba0391dbb4ffc40be3b0476f23")
+ (revision "0"))
+ (package
+ (name "sbcl-trivial-file-size")
+ (version (git-version "0.0.0" revision commit))
+ (home-page "https://github.com/ruricolist/trivial-file-size")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17pp86c9zs4y7i1sh7q9gbfw9iqv6655k7fz8qbj9ly1ypgxp4qs"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (synopsis "Size of a file in bytes in Common Lisp")
+ (description
+ "The canonical way to determine the size of a file in bytes, using Common Lisp,
+is to open the file with an element type of (unsigned-byte 8) and then
+calculate the length of the stream. This is less than ideal. In most cases
+it is better to get the size of the file from its metadata, using a system
+call.
+
+This library exports a single function, file-size-in-octets. It returns the
+size of a file in bytes, using system calls when possible.")
+ (license license:expat))))
+
+(define-public cl-trivial-file-size
+ (sbcl-package->cl-source-package sbcl-trivial-file-size))
+
+(define-public ecl-trivial-file-size
+ (sbcl-package->ecl-package sbcl-trivial-file-size))
+
+(define-public sbcl-trivial-macroexpand-all
+ (let ((commit "933270ac7107477de1bc92c1fd641fe646a7a8a9")
+ (revision "0"))
+ (package
+ (name "sbcl-trivial-macroexpand-all")
+ (version (git-version "0.0.0" revision commit))
+ (home-page "https://github.com/cbaggers/trivial-macroexpand-all")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "191hnn4b5j4i3crydmlzbm231kj0h7l8zj6mzj69r1npbzkas4bd"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (synopsis "Portable macroexpand-all for Common Lisp")
+ (description
+ "This library provides a macroexpand-all function that calls the
+implementation specific equivalent.")
+ (license license:unlicense))))
+
+(define-public cl-trivial-macroexpand-all
+ (sbcl-package->cl-source-package sbcl-trivial-macroexpand-all))
+
+(define-public ecl-trivial-macroexpand-all
+ (sbcl-package->ecl-package sbcl-trivial-macroexpand-all))
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 2f80920ed4..7abe9ab6f0 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -112,14 +112,14 @@
(define-public nss-pam-ldapd
(package
(name "nss-pam-ldapd")
- (version "0.9.10")
+ (version "0.9.11")
(source (origin
(method url-fetch)
(uri (string-append "https://arthurdejong.org/nss-pam-ldapd/"
"nss-pam-ldapd-" version ".tar.gz"))
(sha256
(base32
- "1cqamcr6qpgwxijlr6kg7jspjamjra8w0haan0qssn0yxn95d7c0"))))
+ "1dna3r0q6sjhhlkhcp8x2zkslrd4y7701kk6fl5r940sdph1pmyh"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -146,7 +146,7 @@
`(("linux-pam" ,linux-pam)
("openldap" ,openldap)
("mit-krb5" ,mit-krb5)
- ("python" ,python-2)))
+ ("python" ,python)))
(home-page "https://arthurdejong.org/nss-pam-ldapd")
(synopsis "NSS and PAM modules for LDAP")
(description "nss-pam-ldapd provides a @dfn{Name Service Switch} (NSS)
diff --git a/gnu/packages/patches/aria2-CVE-2019-3500.patch b/gnu/packages/patches/aria2-CVE-2019-3500.patch
deleted file mode 100644
index 891c9047ba..0000000000
--- a/gnu/packages/patches/aria2-CVE-2019-3500.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-Fix CVE-2019-3500:
-
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3500
-https://github.com/aria2/aria2/issues/1329
-
-Patch copied from upstream source repository:
-
-https://github.com/aria2/aria2/commit/37368130ca7de5491a75fd18a20c5c5cc641824a
-
-From 37368130ca7de5491a75fd18a20c5c5cc641824a Mon Sep 17 00:00:00 2001
-From: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
-Date: Sat, 5 Jan 2019 09:32:40 +0900
-Subject: [PATCH] Mask headers
-
----
- src/HttpConnection.cc | 18 ++++++++++++------
- 1 file changed, 12 insertions(+), 6 deletions(-)
-
-diff --git a/src/HttpConnection.cc b/src/HttpConnection.cc
-index 77cb9d27a..be5b97723 100644
---- a/src/HttpConnection.cc
-+++ b/src/HttpConnection.cc
-@@ -102,11 +102,17 @@ std::string HttpConnection::eraseConfidentialInfo(const std::string& request)
- std::string result;
- std::string line;
- while (getline(istr, line)) {
-- if (util::startsWith(line, "Authorization: Basic")) {
-- result += "Authorization: Basic ********\n";
-+ if (util::istartsWith(line, "Authorization: ")) {
-+ result += "Authorization: <snip>\n";
- }
-- else if (util::startsWith(line, "Proxy-Authorization: Basic")) {
-- result += "Proxy-Authorization: Basic ********\n";
-+ else if (util::istartsWith(line, "Proxy-Authorization: ")) {
-+ result += "Proxy-Authorization: <snip>\n";
-+ }
-+ else if (util::istartsWith(line, "Cookie: ")) {
-+ result += "Cookie: <snip>\n";
-+ }
-+ else if (util::istartsWith(line, "Set-Cookie: ")) {
-+ result += "Set-Cookie: <snip>\n";
- }
- else {
- result += line;
-@@ -154,8 +160,8 @@ std::unique_ptr<HttpResponse> HttpConnection::receiveResponse()
- const auto& proc = outstandingHttpRequests_.front()->getHttpHeaderProcessor();
- if (proc->parse(socketRecvBuffer_->getBuffer(),
- socketRecvBuffer_->getBufferLength())) {
-- A2_LOG_INFO(
-- fmt(MSG_RECEIVE_RESPONSE, cuid_, proc->getHeaderString().c_str()));
-+ A2_LOG_INFO(fmt(MSG_RECEIVE_RESPONSE, cuid_,
-+ eraseConfidentialInfo(proc->getHeaderString()).c_str()));
- auto result = proc->getResult();
- if (result->getStatusCode() / 100 == 1) {
- socketRecvBuffer_->drain(proc->getLastBytesProcessed());
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 0c98e61cbc..3c69901a0a 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2119,14 +2119,14 @@ limited to R.")
(define-public r-backports
(package
(name "r-backports")
- (version "1.1.4")
+ (version "1.1.5")
(source
(origin
(method url-fetch)
(uri (cran-uri "backports" version))
(sha256
(base32
- "00zz969vc2gfi5p9q65pzghq2bxm3p9zqgwqswkyz9rgybz5wjzf"))))
+ "0k19w68b2aihyj5mflw3732gkkzs78sssqdns960pdw3yfnkiv33"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/backports")
(synopsis "Reimplementations of functions introduced since R 3.0.0")