aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2019-08-25 15:38:42 -0500
committerBrian Leung <leungbk@mailfence.com>2019-10-09 21:11:07 +0200
commit081fe5ca9730822a089d8eae013025748a97e970 (patch)
tree37969f0121a420a6f47aa4544da67428e13e8f83
parentdc3cd70d20d14e7950b7cfb054ddc9bb3291f669 (diff)
downloadguix-081fe5ca9730822a089d8eae013025748a97e970.tar
guix-081fe5ca9730822a089d8eae013025748a97e970.tar.gz
gnu: Add emacs-ssh-agency.
* gnu/packages/emacs-xyz.scm (emacs-ssh-agency): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6e86c0d7bc..dbd27d31a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18766,6 +18766,34 @@ JIRA issue servers.")
keybindings for skipping from host section to host section.")
(license license:gpl3+))))
+(define-public emacs-ssh-agency
+ (package
+ (name "emacs-ssh-agency")
+ (version "0.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/ssh-agency.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0895n7bss4wdydic1gflr03f2cwdyqywl16gvb599lpn288jhwvz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("dash" ,emacs-dash)))
+ (home-page "https://github.com/magit/ssh-agency")
+ (synopsis "Manage @code{ssh-agent} from Emacs")
+ (description
+ "This package provides functions to startup @code{ssh-agent}, set the
+needed environment variables in Emacs, and prompt for passphrases from within
+Emacs so that pushes and pulls from @code{magit} will not require entering any
+passphrase.
+
+It can also be useful on Unix-like platforms to delay having to enter your
+passphrase until the first time you push to a remote.")
+ (license license:gpl3+)))
+
(define-public emacs-tao-theme
(let ((commit "c5107fbe7e752f4e58c2d2147ff18a1ebb12937c")
(revision "0"))