aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-30 16:15:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-30 20:05:14 +0200
commitbb1e7ed066e97fff06fd10a70be1a582daa97217 (patch)
treee50d281116c1be888295b96650c40637a82aeb56
parent4e1108256917aec3ceb833683f93e61a89d22c37 (diff)
downloadguix-bb1e7ed066e97fff06fd10a70be1a582daa97217.tar
guix-bb1e7ed066e97fff06fd10a70be1a582daa97217.tar.gz
gnu: ruby-tzinfo-data: Don't use unstable tarball.
* gnu/packages/ruby.scm (ruby-tzinfo-data)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/ruby.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ba414747b2..a82e39b796 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4066,17 +4066,16 @@ aware transformations between times in different time zones.")
(version "1.2017.3")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
;; Download from GitHub because the rubygems version does not contain
;; Rakefile or tests.
- (uri (string-append
- "https://github.com/tzinfo/tzinfo-data/archive/v"
- version
- ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/tzinfo/tzinfo-data")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "01wff7syqzikbxalbg3isgxasmvzicr85bzadzkb6bf20bip4v54"))
+ "0v3phl5l3jrm6waxcszqmj2dkjhqawxfsxb6mss7vkp1hlckqcdp"))
;; Remove the known test failure.
;; https://github.com/tzinfo/tzinfo-data/issues/10
;; https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/1587128