aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-01 12:57:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-01 13:33:02 +0100
commit9eb680b1dccd8068c65d12e54d2147220f02b4f2 (patch)
tree191956fe8e320596544ebedfcc13ce6aa858fde4
parent0f5ae473b03fb64ec8efcf76b56037cb8c8cb818 (diff)
downloadguix-9eb680b1dccd8068c65d12e54d2147220f02b4f2.tar
guix-9eb680b1dccd8068c65d12e54d2147220f02b4f2.tar.gz
gnu: Add r-imputeyn.
* gnu/packages/cran.scm (r-imputeyn): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4f4ec592a8..5bacec6a12 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19011,3 +19011,30 @@ OpenMP.")
means/quantiles/hazards from possibly censored and/or truncated data. It also
does regression.")
(license license:gpl2+)))
+
+(define-public r-imputeyn
+ (package
+ (name "r-imputeyn")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "imputeYn" version))
+ (sha256
+ (base32
+ "1b21w1aa5f7yiq8k0wa86wvbg4ij7f6ldwn6asfqwb0b90rvsgvs"))))
+ (properties `((upstream-name . "imputeYn")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-boot" ,r-boot)
+ ("r-emplik" ,r-emplik)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-quadprog" ,r-quadprog)
+ ("r-survival" ,r-survival)))
+ (home-page "https://cran.r-project.org/web/packages/imputeYn/")
+ (synopsis "Impute last largest censored observation under weighted least squares")
+ (description
+ "This package allows for the imputation of the last largest censored
+observantions. This method brings less bias and more efficient estimates for
+AFT models.")
+ (license license:gpl2)))