aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-05-05 22:06:36 +0200
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2021-05-14 22:26:23 +0200
commite026b226cda7e6513cf34ee80b278f60fdc7fbf4 (patch)
tree7b4652a1fcdb73e40e3bd34717162de8e8661bde
parent4d2d2a5e2a7c7a30c27b6dd24a1f3d89f1fae9b9 (diff)
downloadguix-e026b226cda7e6513cf34ee80b278f60fdc7fbf4.tar
guix-e026b226cda7e6513cf34ee80b278f60fdc7fbf4.tar.gz
gnu: Add python-fb-re2.
* gnu/packages/python-xyz.scm (python-fb-re2): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cf0eba3234..2ff0332c7f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,6 +99,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Ellis Kenyő <me@elken.dev>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -181,6 +182,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages regex)
#:use-module (gnu packages sdl)
#:use-module (gnu packages search)
#:use-module (gnu packages scanner)
@@ -1304,6 +1306,30 @@ conventions and aliases in the same expression.")
API for locking files.")
(license license:expat)))
+(define-public python-fb-re2
+ (package
+ (name "python-fb-re2")
+ (version "1.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/facebook/pyre2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0snprxdnh3m45r3b0az4v0l28h90ycmfbybzla6xg1qviwv9w1ak"))))
+ (build-system python-build-system)
+ (inputs
+ `(("re2" ,re2)))
+ (home-page "https://github.com/facebook/pyre2")
+ (synopsis "Python wrapper for RE2")
+ (description "This package provides a Python extension that wraps Google's
+RE2 regular expression library. It implements many of the features of
+Python's built-in @code{re} module with compatible interfaces.")
+ (license license:bsd-3)))
+
(define-public python-filelock
(package
(name "python-filelock")