aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-10-19 22:21:04 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-14 23:52:06 +0200
commitbb94429cb776dc658361e9c26f999c9648d0bd86 (patch)
treeca367812bc7e4432ec27589dbb1cc4112502d85b
parentf84ce99dccb61d417788f86bf4a7978d4716aa5c (diff)
downloadguix-bb94429cb776dc658361e9c26f999c9648d0bd86.tar
guix-bb94429cb776dc658361e9c26f999c9648d0bd86.tar.gz
gnu: Add emacs-wucuo.
* gnu/packages/emacs-xyz.scm (emacs-wucuo): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7b999a9a29..8d8b3f9ea3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -131,6 +131,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages aspell)
#:use-module (gnu packages audio)
#:use-module (gnu packages bash)
#:use-module (gnu packages cmake)
@@ -9843,6 +9844,39 @@ current frame, disabling the mode line, and adding margins to the buffer that
restrict the text width to 80 characters.")
(license license:bsd-3)))
+(define-public emacs-wucuo
+ (package
+ (name "emacs-wucuo")
+ (version "0.2.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/redguardtoo/wucuo")
+ (commit "89b99166768afb811c48a7db7c93c02d51a32b09")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03a6jlbv9axrd9yr0xscq3ni7fipm20ppc51kxy0sn241rplv0pg"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #tn
+ #:test-command '("make" "test")
+ #:phases (modify-phases %standard-phases
+ ;; Set HOME, otherwise tests fail on loading aspell dict.
+ (add-before 'check 'set-home
+ (lambda _ (setenv "HOME" (getcwd)))))))
+ (native-inputs
+ ;; For tests.
+ `(("aspell" ,aspell)
+ ("aspell-dict-en" ,aspell-dict-en)))
+ (home-page "https://github.com/redguardtoo/wucuo")
+ (synopsis "Fast spell checker for camel case code or plain text")
+ (description
+ "Wucuo provides a spell checker on top of either Aspell or Hunspell, and
+relies on Flyspell internally. It operates on the current region or buffer,
+a file, or a complete directory.")
+ (license license:gpl3+)))
+
(define-public emacs-ido-completing-read+
(package
(name "emacs-ido-completing-read+")