aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-17 09:52:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-01-31 09:22:49 +0200
commite217174b7b9046658ac3474d522bde192e9cffb4 (patch)
tree6dc242b722c79074b69ae8aefaa50df55fe08487
parent43dd34c7777a212c99a97da7a2c237158faa9a1b (diff)
downloadguix-e217174b7b9046658ac3474d522bde192e9cffb4.tar
guix-e217174b7b9046658ac3474d522bde192e9cffb4.tar.gz
gnu: texlive-bin: Fix building on riscv64-linux.
* gnu/packages/tex.scm (texlive-bin)[arguments]: Adjust configure-flags for riscv64-linux to skip luajit based binaries. Add phase to skip some tests.
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 95ff37ca6a..d890cb6ad3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -337,13 +337,13 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
"--with-system-teckit"
"--with-system-zlib"
"--with-system-zziplib"
- ;; LuaJIT is not ported to powerpc64le* yet.
- ,@(if (string-prefix? "powerpc64le" (or (%current-target-system)
- (%current-system)))
- '("--disable-luajittex"
- "--disable-luajithbtex"
- "--disable-mfluajit")
- '()))
+ ;; LuaJIT is not ported to some architectures yet.
+ ,@(if (or (target-ppc64le?)
+ (target-riscv64?))
+ '("--disable-luajittex"
+ "--disable-luajithbtex"
+ "--disable-mfluajit")
+ '()))
;; Disable tests on some architectures to cope with a failure of
;; luajiterr.test.
@@ -381,7 +381,8 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
(substitute* "texk/web2c/omegafonts/check.test"
(("^\\./omfonts -ofm2opl \\$srcdir/tests/check tests/xcheck \\|\\| exit 1")
"./omfonts -ofm2opl $srcdir/tests/check tests/xcheck || exit 77"))))
- ,@(if (target-ppc32?)
+ ,@(if (or (target-ppc32?)
+ (target-riscv64?))
;; Some mendex tests fail on some architectures.
`((add-after 'unpack 'skip-mendex-tests
(lambda _