aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:26:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:09 +0200
commitca8ddaaa666c0235dc4054b7c6404c9e8f6c93fb (patch)
tree2c0f27d12f826ac1f7d766d0bd8a73b7e973a6ec
parentef138474f1b3e2b8f725cae51e32f24e298e5118 (diff)
downloadguix-ca8ddaaa666c0235dc4054b7c6404c9e8f6c93fb.tar
guix-ca8ddaaa666c0235dc4054b7c6404c9e8f6c93fb.tar.gz
gnu: emacs-el2org: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-el2org)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f2a83235e4..b250dcc5c2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6841,15 +6841,15 @@ posframe is a child frame displayed within its root window's buffer.
(package
(name "emacs-el2org")
(version "0.6.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/tumashu/el2org/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0gd3km1swwvg2w0kdi7370f54wgrflxn63gjgssfjc1iyc9sbqwq"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tumashu/el2org.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mzddqny6wpg1fv99xrvlv7rxmaifvmy5bvj4in4pldhm4cx4q1b"))))
(build-system emacs-build-system)
(home-page "https://github.com/tumashu/el2org")
(synopsis "Convert Emacs-lisp file to org file")