aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-31 15:39:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-31 16:07:39 +0100
commitad516f400992c5c95d9e2a19694b5c655a370fee (patch)
tree34c6ccfce2ac512d6aa56c9b2b16b442f96ed9e6
parentcd4bf5ecb46ac73e88076de036e24df1280215c9 (diff)
downloadguix-ad516f400992c5c95d9e2a19694b5c655a370fee.tar
guix-ad516f400992c5c95d9e2a19694b5c655a370fee.tar.gz
gnu: Add python-xlrd-1.
* gnu/packages/python-xyz.scm (python-xlrd-1): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4f77fae8d0..1f40f982ce 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11419,6 +11419,32 @@ Unicode-aware. It is not intended as an end-user tool.")
(define-public python2-xlrd
(package-with-python2 python-xlrd))
+;; We need this for python-anndata
+(define-public python-xlrd-1
+ (package
+ (inherit python-xlrd)
+ (name "python-xlrd")
+ (version "1.2.0")
+ (source (origin
+ ;; The tests are not included in the PyPI archive.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/python-excel/xlrd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sm5p0ii5ayh52ak1jpw0n1kgsv72vdwwp8c3z13l8yf4irsb587"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Some tests depend on writing a temporary file to the user's home
+ ;; directory.
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (setenv "HOME" "/tmp"))))))))
+
;;; Note: this package is unmaintained since 2018 (archived on GitHub).
(define-public python-xlwt
(package