aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-30 16:08:41 +0100
committerMarius Bakke <marius@gnu.org>2022-01-30 17:04:34 +0100
commit753cacb1addfc517b2f4dc129e9da862ca2e70b1 (patch)
treecb3a35ddda17e63037a9ba766b49e223bf722457
parent5c9c7856a6074027db762ba6c094dba07e62ba13 (diff)
downloadguix-753cacb1addfc517b2f4dc129e9da862ca2e70b1.tar
guix-753cacb1addfc517b2f4dc129e9da862ca2e70b1.tar.gz
gnu: util-linux-with-udev: Remove input labels.
* gnu/packages/linux.scm (util-linux+udev)[inputs]: Use MODIFY-INPUTS.
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fc67eae365..f4f8d2a769 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1999,8 +1999,8 @@ block devices, UUIDs, TTYs, and many other tools.")
util-linux
(name "util-linux-with-udev")
(inputs
- `(("udev" ,eudev)
- ,@(package-inputs util-linux)))))
+ (modify-inputs (package-inputs util-linux)
+ (prepend eudev)))))
;; This is mostly equivalent to the upstream release version v2.37.3, except
;; that the upstream tarball was generated improperly, which breaks the build.