aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-07 20:32:47 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:17 +0100
commit6151120a71507017bfea82693c7e614b341e50e7 (patch)
tree450598b7a8a4ef309846cee682e2394b75a72095
parent5e1c9d242abe6c992c4435d7cfb035d2b6583679 (diff)
downloadguix-6151120a71507017bfea82693c7e614b341e50e7.tar
guix-6151120a71507017bfea82693c7e614b341e50e7.tar.gz
gnu: python-pillow: Fix build.
* gnu/packages/python.scm (python-pillow)[check-installed]: Add installed site-package to PYTHONPATH.
-rw-r--r--gnu/packages/python.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ea6fc83bbf..fb5d2fd16a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3991,9 +3991,12 @@ services for your Python modules and applications.")
`(#:phases (modify-phases %standard-phases
(add-after
'install 'check-installed
- (lambda _
+ (lambda* (#:key outputs inputs #:allow-other-keys)
(begin
(setenv "HOME" (getcwd))
+ ;; Make installed package available for running the
+ ;; tests
+ (add-installed-pythonpath inputs outputs)
(and (zero? (system* "python" "selftest.py"
"--installed"))
(zero? (system* "python" "test-installed.py"))))))