aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-05 13:51:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:41:04 +0100
commit0a500745c7a34dc7c37cc08c57c77813a5765739 (patch)
tree094d5978f1cac6c11f7331584d93c11dadcca060
parent2089bca52af722dd125e5595695207d3017c4f4d (diff)
downloadguix-0a500745c7a34dc7c37cc08c57c77813a5765739.tar
guix-0a500745c7a34dc7c37cc08c57c77813a5765739.tar.gz
gnu: file-roller: Update to 3.28.0.
* gnu/packages/gnome.scm (file-roller): Update to 3.28.0. [build-system]: Use meson-build-system. [native-inputs]: Add desktop-file-utils, gtk+:bin, and glib:bin. [arguments]: Remove.
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4c0a6da2db..69d9c63f88 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4601,7 +4601,7 @@ share them with others via social networking and more.")
(define-public file-roller
(package
(name "file-roller")
- (version "3.26.2")
+ (version "3.28.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4609,20 +4609,14 @@ share them with others via social networking and more.")
name "-" version ".tar.xz"))
(sha256
(base32
- "19d8pc5z2xzhnicgaysxmwx3ghwzl4cw8kygd6nsw69g3j77nrry"))))
- (build-system glib-or-gtk-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'install 'skip-gtk-update-icon-cache
- (lambda _
- ;; Don't create 'icon-theme.cache'
- (substitute* (find-files "data" "^Makefile$")
- (("gtk-update-icon-cache") (which "true")))
- #t)))))
+ "15pn2m80x45bzibig4zrqybnbr0n1f9wpqx7f2p6difldns3jwf1"))))
+ (build-system meson-build-system)
(native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("gtk+" ,gtk+ "bin") ; gtk-update-icon-cache
+ ("glib:bin" ,glib "bin")))
;; TODO: Add libnautilus.
(inputs
`(("gtk+" ,gtk+)