aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-03 14:53:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-25 00:14:43 -0400
commit24be67517cd40b766b5c38a39de94ae4421153f8 (patch)
treede7ae7bb481f954bed5e141dac000341c6e2aaf5
parenta8cdfd53db4ef839cba28e0cb283d2c3dfdb1f1a (diff)
downloadguix-24be67517cd40b766b5c38a39de94ae4421153f8.tar
guix-24be67517cd40b766b5c38a39de94ae4421153f8.tar.gz
gnu: Add ruby-ruby-parser.
* gnu/packages/ruby.scm (ruby-ruby-parser): New variable.
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1b017a1ea7..85bf9169db 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages c)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
@@ -4328,6 +4329,31 @@ Amongst the included tools are @code{Sexp}, @code{SexpProcessor} and
(home-page "https://github.com/seattlerb/sexp_processor")
(license license:expat)))
+(define-public ruby-ruby-parser
+ (package
+ (name "ruby-ruby-parser")
+ (version "3.14.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby_parser" version))
+ (sha256
+ (base32
+ "09qcdyjjw3p7g6cjm5m9swkms1xnv35ndiy7yw24cas16qrhha6c"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("hoe" ,ruby-hoe)
+ ("racc" ,ruby-racc)
+ ("unifdef" ,unifdef)))
+ (propagated-inputs
+ `(("ruby-sexp-processor" ,ruby-sexp-processor)))
+ (home-page "https://github.com/seattlerb/ruby_parser/")
+ (synopsis "Ruby parser written in pure Ruby")
+ (description "The ruby_parser (RP) package provides a Ruby parser written
+in pure Ruby. It outputs S-expressions which can be manipulated and converted
+back to Ruby via the @code{ruby2ruby} library.")
+ (license license:expat)))
+
(define-public ruby-prawn-manual-builder
(package
(name "ruby-prawn-manual-builder")