aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-06-25 01:58:10 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-06-25 02:55:12 +0200
commit1a629f00761f807773a195febb0c00b14158f5e2 (patch)
tree312cff9db22fbccbcc1b4bf3ea7269f96f192cb1
parent8d26b41290331a1cc2c334cdf88d21c94e95d24d (diff)
downloadguix-1a629f00761f807773a195febb0c00b14158f5e2.tar
guix-1a629f00761f807773a195febb0c00b14158f5e2.tar.gz
gnu: rust-rayon-core-1: Update to 1.7.1.
* gnu/packages/crates-io.scm (rust-rayon-core-1): Update to 1.7.1. [arguments]: Don't skip build. Replace rust-num-cpus-1.10 with 1.11. Disable tests.
-rw-r--r--gnu/packages/crates-io.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b49c4b6efc..80208004db 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18495,7 +18495,7 @@ accessors.")
(define-public rust-rayon-core-1
(package
(name "rust-rayon-core")
- (version "1.7.0")
+ (version "1.7.1")
(source
(origin
(method url-fetch)
@@ -18504,16 +18504,18 @@ accessors.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1ac55kpnh2390ah7r071vnjbiy308qpznql0n597x5dgxx39pa08"))))
+ "101jjwkcfw5jk31695gbdm163iicc2pz349q6l8lwj43j3c1abp9"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
+ `(;; One of the tests attempts to overflow the stack, but the compiler
+ ;; has since gotten smarter and the test became defective.
+ #:tests? #f
#:cargo-inputs
(("rust-crossbeam-deque" ,rust-crossbeam-deque-0.7)
("rust-crossbeam-queue" ,rust-crossbeam-queue-0.2)
("rust-crossbeam-utils" ,rust-crossbeam-utils-0.7)
("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-num-cpus" ,rust-num-cpus-1.10))
+ ("rust-num-cpus" ,rust-num-cpus-1.11))
#:cargo-development-inputs
(("rust-libc" ,rust-libc-0.2)
("rust-rand" ,rust-rand-0.7)