aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-04 20:22:27 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-04 20:27:04 +0000
commitfe5969656adc0c799deaf06d90a9628b78e7b232 (patch)
treea38bebe38617adc3639e3fa46556c965ae24c832
parentb4c684cdf389de435a0bd5a05d2772a168bed7fa (diff)
downloadguix-fe5969656adc0c799deaf06d90a9628b78e7b232.tar
guix-fe5969656adc0c799deaf06d90a9628b78e7b232.tar.gz
gnu: mongo-tools: Fix build.
I guess this broke when upgrading go. I did try upgrading to the later patch and minor releases, but they had similar problems, so lets upgrade separately. * gnu/packages/databases.scm (mongo-tools)[arguments]: Add patch-source phase.
-rw-r--r--gnu/packages/databases.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d7b35834fe..0fa6d451ed 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2868,6 +2868,14 @@ transforms idiomatic python function calls to well-formed SQL queries.")
(delete-file-recursively
"src/github.com/mongodb/mongo-tools/vendor")
#t))
+ (add-after 'delete-bundled-source-code 'patch-source
+ (lambda _
+ ;; Remove a redundant argument that causes compilation to fail.
+ (substitute*
+ "src/github.com/mongodb/mongo-tools/mongorestore/filepath.go"
+ (("skipping restore of system.profile collection\", db)")
+ "skipping restore of system.profile collection\")"))
+ #t))
;; We don't need to install the source code for end-user applications
(delete 'install-source)
(replace 'build