aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-09-04 17:26:14 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-09-04 17:31:09 +0530
commit906a396bff28ba46b37014a0efc5d4fbf417dc82 (patch)
tree5e6df9f1846e6465e84a387b855d5ed2608bde73
parent6300ba5b6669e6e1a3864144390a358b8c260296 (diff)
downloadguix-906a396bff28ba46b37014a0efc5d4fbf417dc82.tar
guix-906a396bff28ba46b37014a0efc5d4fbf417dc82.tar.gz
gnu: ghc-zlib: Enable tests.
* gnu/packages/haskell.scm (ghc-zlib)[arguments]: Enable tests. Allow building with newer tasty. [native-inputs]: Add ghc-quickcheck, ghc-tasty, ghc-tasty-hunit and ghc-tasty-quickcheck.
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e7072633de..b8ae26346e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2078,9 +2078,13 @@ literals.")
(base32
"1vbzf0awb6zb456xf48za1kl22018646cfzq4frvxgb9ay97vk0d"))))
(build-system haskell-build-system)
- ;; Tests require older versions of testy.
- (arguments `(#:tests? #f))
+ (arguments `(#:configure-flags (list "--allow-newer=tasty")))
(inputs `(("zlib" ,zlib)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
(home-page "https://hackage.haskell.org/package/zlib")
(synopsis
"Compression and decompression in the gzip and zlib formats")