aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-14 23:11:49 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit0b61d503024c38e97fa9f9d3e1cf0153d8120d2b (patch)
tree31a7f17f484fb93b72e0d7d38ee7384c09d89560
parenta306190f885d5429a5c924d6a160d5c8b1cb8225 (diff)
downloadguix-0b61d503024c38e97fa9f9d3e1cf0153d8120d2b.tar
guix-0b61d503024c38e97fa9f9d3e1cf0153d8120d2b.tar.gz
gnu: ghc-vector: Update to 0.11.0.0.
* gnu/packages/haskell.scm (ghc-vector): Update to 0.11.0.0.
-rw-r--r--gnu/packages/haskell.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2c8e06f010..5fea33161f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1114,7 +1114,7 @@ is also parametric in the input stream type.")
(define-public ghc-vector
(package
(name "ghc-vector")
- (version "0.10.12.2")
+ (version "0.11.0.0")
(outputs '("out" "doc"))
(source
(origin
@@ -1125,7 +1125,7 @@ is also parametric in the input stream type.")
".tar.gz"))
(sha256
(base32
- "01hc71k1z9m0g0dv4zsvq5d2dvbgyc5p01hryw5c53792yi2fm25"))))
+ "1r1jlksy7b0kb0fy00g64isk6nyd9wzzdq31gx5v1wn38knj0lqa"))))
(build-system haskell-build-system)
(inputs
`(("ghc-quickcheck" ,ghc-quickcheck)))
@@ -1133,12 +1133,13 @@ is also parametric in the input stream type.")
(propagated-inputs
`(("ghc-primitive" ,ghc-primitive)))
(arguments
- `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+ `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
(home-page "https://github.com/haskell/vector")
(synopsis "Efficient Arrays")
- (description "An efficient implementation of Int-indexed arrays (both
-mutable and immutable), with a powerful loop optimisation framework.")
- (license bsd-3)))
+ (description "This library provides an efficient implementation of
+Int-indexed arrays (both mutable and immutable), with a powerful loop
+optimisation framework.")
+ (license bsd-3)))
(define-public ghc-network
(package