aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-10 00:25:41 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:50:03 +0100
commit29a705a60fe690517da837b963978994be9eecc9 (patch)
tree3ca9fd1fe38d4902eac3c04b6f3966c2646c715d
parent9ec997581b262d53e2e31f17fb010050a3469f3c (diff)
downloadguix-29a705a60fe690517da837b963978994be9eecc9.tar
guix-29a705a60fe690517da837b963978994be9eecc9.tar.gz
gnu: Add rust-iron-0.6.
* gnu/packages/crates-io.scm (rust-iron-0.6): New variable.
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7dc6d2470d..1477dfcc02 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17659,6 +17659,40 @@ stable toolchain.")
Rust.")
(license (list license:expat license:asl2.0))))
+(define-public rust-iron-0.6
+ (package
+ (name "rust-iron")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "iron" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1s4mf8395f693nhwsr0znw3j5frzn56gzllypyl50il85p50ily6"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-hyper" ,rust-hyper-0.10)
+ ("rust-hyper-native-tls" ,rust-hyper-native-tls-0.3)
+ ("rust-log" ,rust-log-0.3)
+ ("rust-mime-guess" ,rust-mime-guess-1)
+ ("rust-modifier" ,rust-modifier-0.1)
+ ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-plugin" ,rust-plugin-0.2)
+ ("rust-typemap" ,rust-typemap-0.3)
+ ("rust-url" ,rust-url-1))))
+ (home-page "https://github.com/iron/iron")
+ (synopsis "Extensible, concurrency focused web development in Rust")
+ (description
+ "Iron is a high level web framework built in and for Rust. It is highly
+concurrent and can scale horizontally on more machines behind a load balancer
+or by running more threads on a more powerful machine. Iron avoids the
+bottlenecks encountered in highly concurrent code by avoiding shared writes
+and locking in the core framework.")
+ (license license:expat)))
+
(define-public rust-is-executable
(package
(name "rust-is-executable")