aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Le Bouter <lle-bout@zaclys.net>2021-02-08 03:13:53 +0100
committerChris Marusich <cmmarusich@gmail.com>2021-03-23 23:19:57 -0700
commite9938dc8f0e081e4407a96502a04ea63f07e5a8c (patch)
tree9c95fdcd2de4b449ea31a1e8cf375fd72ebc1fa2
parent69b3907adf6864e5d133797f1dad51d5a974c796 (diff)
downloadguix-e9938dc8f0e081e4407a96502a04ea63f07e5a8c.tar
guix-e9938dc8f0e081e4407a96502a04ea63f07e5a8c.tar.gz
gnu: texlive-bin: Fix compilation on powerpc64le*.
* gnu/packages/tex.scm (texlive-bin)[arguments]: Append "--disable-luajittex" and "--disable-mfluajit" to keyword argument "#:configure-flags" on powerpc64le* because LuaJIT is not ported to powerpc64le* yet. Also set "#:tests?" to "#f" on powerpc64le*. Signed-off-by: Chris Marusich <cmmarusich@gmail.com>
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c0f4ff0fcd..508537acda 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,14 +343,23 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
"--with-system-teckit"
"--with-system-xpdf"
"--with-system-zlib"
- "--with-system-zziplib")
-
- ;; Disable tests on mips64/aarch64 to cope with a failure of luajiterr.test.
- ;; XXX FIXME fix luajit properly on mips64 and aarch64.
+ "--with-system-zziplib"
+ ;; LuaJIT is not ported to powerpc64le* yet.
+ ,@(if (string-prefix? "powerpc64le" (or (%current-target-system)
+ (%current-system)))
+ '("--disable-luajittex"
+ "--disable-mfluajit")
+ '()))
+
+ ;; Disable tests on some architectures to cope with a failure of
+ ;; luajiterr.test.
+ ;; XXX FIXME fix luajit properly on these architectures.
#:tests? ,(let ((s (or (%current-target-system)
(%current-system))))
(not (or (string-prefix? "aarch64" s)
- (string-prefix? "mips64" s))))
+ (string-prefix? "mips64" s)
+ (string-prefix? "powerpc64le" s))))
+
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'configure-ghostscript-executable