aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-03-24 19:22:43 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-03-24 19:22:43 +0100
commitd999fc689e27569698d72d5e77eba986a9b016d7 (patch)
tree1d6945734dc561f07abcad2df713bafeb85f1252
parent55685e45be072b8b688f5a2bda4fc68147febd3f (diff)
downloadguix-d999fc689e27569698d72d5e77eba986a9b016d7.tar
guix-d999fc689e27569698d72d5e77eba986a9b016d7.tar.gz
gnu: guile-mastodon: Update to 0.0.1-1.74b75bc.
* gnu/packages/guile-xyz.scm (guile-mastodon): Update to 0.0.1-1.74b75bc. [source]: Remove Guile-3.0 snippet since this new release brings Guile-3.0 support.
-rw-r--r--gnu/packages/guile-xyz.scm65
1 files changed, 29 insertions, 36 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 461b9e04bf..c798bed817 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1313,44 +1313,37 @@ Scheme by using Guileā€™s foreign function interface.")
(deprecated-package "guile3.0-newt" guile-newt))
(define-public guile-mastodon
- (package
- (name "guile-mastodon")
- (version "0.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://framagit.org/prouby/guile-mastodon.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1vblf3d1bbwna3l09p2ap5y8ycvl549bz6whgk78imyfmn28ygry"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Allow builds with Guile 3.0.
- (substitute* "configure.ac"
- (("^PKG_CHECK.*") "")
- (("^GUILE_PKG.*")
- "GUILE_PKG([3.0 2.2])\n"))
- #t))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("emacs" ,emacs-minimal)
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)))
- (inputs
- `(("guile" ,guile-3.0)
- ("gnutls" ,gnutls)
- ("guile-json" ,guile-json-4)))
- (home-page "https://framagit.org/prouby/guile-mastodon")
- (synopsis "Guile Mastodon REST API module")
- (description "This package provides Guile modules to access the
+ (let ((commit "74b75bcf547df92acee1e0466ecd7ec07f775392")
+ (revision "1"))
+ (package
+ (name "guile-mastodon")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://framagit.org/prouby/guile-mastodon.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1wx5h6wa9c0na8mrnr2nv1nzjvq68zyrly8yyp11dsskhaw4y33h"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("emacs" ,emacs-minimal)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("guile" ,guile-3.0)
+ ("gnutls" ,gnutls)
+ ("guile-json" ,guile-json-4)))
+ (home-page "https://framagit.org/prouby/guile-mastodon")
+ (synopsis "Guile Mastodon REST API module")
+ (description "This package provides Guile modules to access the
@uref{https://docs.joinmastodon.org/api/, REST API of Mastodon}, a federated
microblogging service.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public guile-parted
(package