aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Le Bouter <lle-bout@zaclys.net>2021-02-09 06:10:02 +0100
committerChris Marusich <cmmarusich@gmail.com>2021-03-23 23:19:57 -0700
commitb50f42680352213beb64c248c1af2f9dcc1612fc (patch)
tree26fd4402e0e41aba29fa43a99f6ff82fb62ad5b1
parent1a0f4013d33535ed9b8518cfb3ac502f48132fd8 (diff)
downloadguix-b50f42680352213beb64c248c1af2f9dcc1612fc.tar
guix-b50f42680352213beb64c248c1af2f9dcc1612fc.tar.gz
gnu: libelf: Fix compilation for powerpc64le-linux.
* gnu/packages/elf.scm (libelf)[arguments]: Modify replacement 'configure phase to invoke "./configure" with "--host=powerpc64le-unknown-linux-gnu" on powerpc64le-linux. Signed-off-by: Chris Marusich <cmmarusich@gmail.com>
-rw-r--r--gnu/packages/elf.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 2e21cab48d..aab912648b 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Mark Wielaard <mark@klomp.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -211,6 +212,10 @@ static analysis of the ELF binaries at hand.")
(setenv "CONFIG_SHELL" (which "bash"))
(invoke "./configure"
(string-append "--prefix=" out)
+ ,@(if (string=? "powerpc64le-linux"
+ (%current-system))
+ '("--host=powerpc64le-unknown-linux-gnu")
+ '())
,@(if (string=? "aarch64-linux"
(%current-system))
'("--host=aarch64-unknown-linux-gnu")