aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2020-06-09 23:35:56 -0700
committerChris Marusich <cmmarusich@gmail.com>2021-03-23 23:19:58 -0700
commit65c46e79e0495fe4d32f6f2725d7233fff10fd70 (patch)
tree721f5b6bcc34fa5e0fd776f7de48159dc26c5956
parent93f21e1a35eec940be754fea0303cc649eacd395 (diff)
downloadguix-65c46e79e0495fe4d32f6f2725d7233fff10fd70.tar
guix-65c46e79e0495fe4d32f6f2725d7233fff10fd70.tar.gz
gnu: sed: Make it build on SELinux-enabled kernels.
Fixes: <https://bugs.gnu.org/41498>. * gnu/packages/base.scm (sed)[arguments]: New field. This adds a snippet, equivalent to the patch submitted upstream, which fixes an issue that prevents sed from building on SELinux-enabled kernels. Adjusted by Efraim Flashner to apply to master.
-rw-r--r--gnu/packages/base.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 7c5ac61f01..f0f9353398 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -148,6 +148,22 @@ including, for example, recursive directory searching.")
(base32
"0alqagh0nliymz23kfjg6g9w3cr086k0sfni56gi8fhzqwa3xksk"))))
(build-system gnu-build-system)
+ (arguments
+ ;; TODO: When merging this into core-updates, keep the version of
+ ;; this code (with comment!) applied as a snippet.
+ `(,@(if (string-prefix? "powerpc64le" (or (%current-target-system)
+ (%current-system)))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'allow-building-on-selinux-systems
+ (lambda _
+ (substitute* "Makefile.in"
+ (("^ abs_srcdir='\\$\\(abs_srcdir\\)'.*" previous-line)
+ (string-append
+ previous-line
+ " CONFIG_HEADER='$(CONFIG_HEADER)'\t\t\\\n")))
+ #t))))
+ '())))
(synopsis "Stream editor")
(native-inputs
`(("perl" ,perl))) ;for tests