aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2018-12-27 07:25:12 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-27 09:37:40 +0100
commit2e951707f505db2d6e3a94a842b4319aa9b07e39 (patch)
tree0a3bdf20d48b6259d2cedda5d5a2fb2b4c3a54df
parent2939fe7b3cb5a53daebab7b7734e29be3ba8d153 (diff)
downloadguix-2e951707f505db2d6e3a94a842b4319aa9b07e39.tar
guix-2e951707f505db2d6e3a94a842b4319aa9b07e39.tar.gz
gnu: Add ocaml-yojson.
* gnu/packages/ocaml.scm (ocaml-yojson): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a5193c7b3c..aeff7b50e9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5073,3 +5073,32 @@ protocols evolve. Biniou is vastly equivalent to JSON in terms of
functionality but allows implementations several times faster (4 times faster
than yojson), with 25-35% space savings.")
(license license:bsd-3)))
+
+(define-public ocaml-yojson
+ (package
+ (name "ocaml-yojson")
+ (version "1.4.1")
+ (home-page "https://github.com/ocaml-community/yojson")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nwsfkmqpyfab4rxq76q8ff7giyanghw08094jyrp275v99zdjr9"))))
+ (build-system dune-build-system)
+ (inputs
+ `(("ocaml-biniou" ,ocaml-biniou)
+ ("ocaml-easy-format" ,ocaml-easy-format)
+ ("ocaml-cppo" ,ocaml-cppo)))
+ (synopsis "Low-level JSON library for OCaml")
+ (description "Yojson is an optimized parsing and printing library for the
+JSON format. It addresses a few shortcomings of json-wheel including 2x
+speedup, polymorphic variants and optional syntax for tuples and variants.
+@code{ydump} is a pretty printing command-line program provided with the
+yojson package. The program @code{atdgen} can be used to derive OCaml-JSON
+serializers and deserializers from type definitions.")
+ (license license:bsd-3)))