aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-28 13:26:02 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-28 13:26:02 +0100
commit11d44d0b2a701cf428dbb24b9221a9620662b948 (patch)
tree224ad8d32ce2b0d3665c2b7e5fb06bf727e7105b
parent4bc00b563162edf35c56641472aef258076eeaab (diff)
downloadguix-11d44d0b2a701cf428dbb24b9221a9620662b948.tar
guix-11d44d0b2a701cf428dbb24b9221a9620662b948.tar.gz
gnu: musescore: Update to 3.0.
* gnu/packages/music.scm (musescore): Update to 3.0. [build-system]: Switch to CMake build system. [arguments]: Apply build system change. [native-inputs]: Remove unnecessary "cmake" input.
-rw-r--r--gnu/packages/music.scm29
1 files changed, 11 insertions, 18 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e16e64af73..02c42f897f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3610,7 +3610,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(define-public musescore
(package
(name "musescore")
- (version "2.3.2")
+ (version "3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3619,7 +3619,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(file-name (git-file-name name version))
(sha256
(base32
- "0ncv0xfmq87plqa43cm0fpidlwzz1nq5s7h7139llrbc36yp3pr1"))
+ "0g8n8xpw5d6wh8bwbvy12sinl9i0ir009sr28i4izr28lr4x8v50"))
(modules '((guix build utils)))
(snippet
;; Un-bundle OpenSSL and remove unused libraries.
@@ -3634,27 +3634,21 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
"thirdparty/openssl"
"thirdparty/portmidi"))
#t))))
- (build-system gnu-build-system)
+ (build-system cmake-build-system)
(arguments
- `(#:make-flags
- `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
- "USE_SYSTEM_FREETYPE=ON"
- "DOWNLOAD_SOUNDFONT=OFF"
- ;; The following is not supported since Qt 5.11. May be removed in
- ;; a future release.
- "BUILD_WEBKIT=OFF")
- ;; There are tests, but no simple target to run. The command
- ;; used to run them is:
+ `(#:configure-flags
+ `("-DUSE_SYSTEM_FREETYPE=ON"
+ "-DBUILD_WEBENGINE=OFF"
+ "-DDOWNLOAD_SOUNDFONT=OFF")
+ ;; There are tests, but no simple target to run. The command used to
+ ;; run them is:
;;
;; make debug && sudo make installdebug && cd \
;; build.debug/mtest && make && ctest
;;
;; Basically, it requires to start a whole new build process.
;; So we simply skip them.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ #:tests? #f))
(inputs
`(("alsa-lib" ,alsa-lib)
("freetype" ,freetype)
@@ -3673,8 +3667,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
("qtsvg" ,qtsvg)
("qtxmlpatterns" ,qtxmlpatterns)))
(native-inputs
- `(("cmake" ,cmake)
- ("pkg-config" ,pkg-config)
+ `(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
(synopsis "Music composition and notation software")
(description "MuseScore is a music score typesetter. Its main purpose is