aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-08-09 01:08:10 -0500
committerEric Bavier <bavier@member.fsf.org>2017-08-09 01:56:53 -0500
commitd84b09e937e7c5529d124744c84574a0637c3410 (patch)
tree20955d728402541161d5718b9fd848977e06138d
parent05cca6ce90407f19619a097815c53e5bd90d7780 (diff)
downloadguix-d84b09e937e7c5529d124744c84574a0637c3410.tar
guix-d84b09e937e7c5529d124744c84574a0637c3410.tar.gz
gnu: dealii: Update to 8.5.0.
* gnu/packages/maths.scm (dealii): Update to 8.5.0. [arguments]: Delete 'hint-example-prefix phase, which would need adjusting for this version. Users can use e.g. 'export DEAL_II_DIR=$GUIX_ENVIRONMENT'. Adjust configuration flags.
-rw-r--r--gnu/packages/maths.scm23
1 files changed, 6 insertions, 17 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 78c77b6813..6597191805 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2693,7 +2693,7 @@ revised simplex and the branch-and-bound methods.")
(define-public dealii
(package
(name "dealii")
- (version "8.4.1")
+ (version "8.5.0")
(source
(origin
(method url-fetch)
@@ -2701,7 +2701,7 @@ revised simplex and the branch-and-bound methods.")
"download/v" version "/dealii-" version ".tar.gz"))
(sha256
(base32
- "1bdksvvyp1rj37df1ndh8j3x9nzpc3sazw8nd0hzvnlw0qnyk800"))
+ "0yfpy4zh8j7hmqakw17zdlmvfdcmhwgs66wcb716plc4y7v3z4g6"))
(modules '((guix build utils)))
(snippet
;; Remove bundled sources: UMFPACK, TBB, muParser, and boost
@@ -2720,21 +2720,10 @@ revised simplex and the branch-and-bound methods.")
("suitesparse" ,suitesparse))) ;for UMFPACK
(arguments
`(#:build-type "DebugRelease" ;only supports Release, Debug, or DebugRelease
- #:configure-flags '("-DCOMPAT_FILES=OFF") ;Follow new directory structure
- #:phases (modify-phases %standard-phases
- (add-after
- 'install 'hint-example-prefix
- ;; Set Cmake hints in examples so that they can find this
- ;; deal.II when configuring.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref %outputs "out"))
- (exmpl (string-append out "/share/doc"
- "/dealii/examples")))
- (substitute* (find-files exmpl "CMakeLists.txt")
- (("([[:space:]]*HINTS.*)\n" _ line)
- (string-append line " $ENV{HOME}/.guix-profile "
- out "\n")))
- #t))))))
+ #:configure-flags
+ ;; Work around a bug in libsuitesparseconfig linking
+ ;; see https://github.com/dealii/dealii/issues/4745
+ '("-DCMAKE_POSITION_INDEPENDENT_CODE:BOOL=ON")))
(home-page "https://www.dealii.org")
(synopsis "Finite element library")
(description