aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-07-26 11:37:30 +0100
committerChristopher Baines <mail@cbaines.net>2017-08-09 23:50:10 +0100
commitc795bc79d93ea885921e51a68cd13dfa762a3254 (patch)
tree32033a1ed00a29c0ab0f190de1f200cbc9024015
parent4c6c683862579b9f1fa6782b9482054eb1059225 (diff)
downloadguix-c795bc79d93ea885921e51a68cd13dfa762a3254.tar
guix-c795bc79d93ea885921e51a68cd13dfa762a3254.tar.gz
gnu: Add python-tornado-http-auth.
* gnu/packages/python.scm (python-tornado-http-auth): New variable.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index af320dfc0d..731fee6333 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6560,6 +6560,29 @@ connection to each user.")
("python2-singledispatch" ,python2-singledispatch)
,@(package-propagated-inputs tornado))))))
+(define-public python-tornado-http-auth
+ (package
+ (name "python-tornado-http-auth")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tornado-http-auth" version))
+ (sha256
+ (base32
+ "0znrgqd7k2s4ia474xizi6h3061zj4sn5n6cq76bkwl3wwshifn5"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-tornado" ,python-tornado)))
+ (home-page
+ "https://github.com/gvalkov/tornado-http-auth")
+ (synopsis
+ "Digest and basic authentication module for Tornado")
+ (description
+ "Provides support for adding authentication to services using the Tornado
+web framework, either via the basic or digest authentication schemes.")
+ (license license:asl2.0)))
+
;; the python- version can be removed with python-3.5
(define-public python-backports-abc
(package