aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-09 18:12:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-09 20:08:13 +0200
commit5d0afe88497d81ac378c59890c1f517e6fc22bb2 (patch)
tree2596bc011c07abdd7d50ba650639d9d6b57cc144
parent0bae5fd6a703ff82aad3d749da0209aac6a9c1fb (diff)
downloadguix-5d0afe88497d81ac378c59890c1f517e6fc22bb2.tar
guix-5d0afe88497d81ac378c59890c1f517e6fc22bb2.tar.gz
gnu: Add r-fit-models.
* gnu/packages/statistics.scm (r-fit-models): New variable.
-rw-r--r--gnu/packages/statistics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 4c04832fff..fae5d8d8d1 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4650,6 +4650,34 @@ analysis} (PCA) by projection pursuit.")
estimation and robust multivariate analysis with high breakdown point.")
(license license:gpl2+)))
+(define-public r-fit-models
+ (package
+ (name "r-fit-models")
+ (version "0.5-14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fit.models" version))
+ (sha256
+ (base32
+ "0vjbzmx0ambm6yzidb4vbgmhclwzwv2iz2cwl54ccdkvx4cx3fck"))))
+ (properties `((upstream-name . "fit.models")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)))
+ (home-page "http://cran.r-project.org/web/packages/fit.models")
+ (synopsis "Compare fitted models")
+ (description
+ "The @code{fit.models} function and its associated methods (coefficients, print,
+summary, plot, etc.) were originally provided in the @code{robust} package to
+compare robustly and classically fitted model objects. The aim of the
+@code{fit.models} package is to separate this fitted model object comparison
+functionality from the robust package and to extend it to support fitting
+methods (e.g., classical, robust, Bayesian, regularized, etc.) more
+generally.")
+ ;; Any version of the GPL
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-trimcluster
(package
(name "r-trimcluster")