aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-08-08 21:02:32 +0300
committerArun Isaac <arunisaac@systemreboot.net>2017-08-10 14:37:17 +0530
commit1ee879e96705e6381c056358b7f426f2cf99c1df (patch)
treece9ff5acf2fbc673c4d392a36f7244e78ad49ab8
parenta88adeb34356e2b4b11595f868f2b09ee8b9f58c (diff)
downloadguix-1ee879e96705e6381c056358b7f426f2cf99c1df.tar
guix-1ee879e96705e6381c056358b7f426f2cf99c1df.tar.gz
gnu: Add emacs-gitpatch.
By the way, “gitpatch.el” says different version than release tarball. Do I need to ask a developer? --8<---------------cut here---------------start------------->8--- ;; Author: Feng Shu <tumashu@163.com> ;; Homepage: https://github.com/tumashu/gitpatch ;; Keywords: convenience ;; Package-Requires: ((emacs "24.3")) ;; Version: 0.10 --8<---------------cut here---------------end--------------->8--- >From 9eddf07fa401468738c2f48a25e51ddef2a3ceed Mon Sep 17 00:00:00 2001 From: Oleg Pykhalov <go.wigust@gmail.com> Date: Sat, 29 Jul 2017 14:22:48 +0300 Subject: [PATCH] gnu: Add emacs-gitpatch. * gnu/packages/emacs.scm (emacs-gitpatch): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 16aacaadb3..2cb37635d8 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5262,3 +5262,24 @@ editing RPM spec files.")
the last git commit message for the current line. This uses git-blame
internally.")
(license license:gpl3+)))
+
+(define-public emacs-gitpatch
+ (package
+ (name "emacs-gitpatch")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/tumashu/gitpatch/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yj6pmic541lcnscjin300k380qp9xdfprs55xg1q57jrkq6f6k7"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tumashu/gitpatch")
+ (synopsis "Mail git patch from Emacs")
+ (description "@code{emacs-gitpatch} lets users easily send git patches,
+created by @code{git format-patch}, from @code{magit}, @code{dired} and
+@code{ibuffer} buffers.")
+ (license license:gpl3+)))