aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 15:55:08 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 14:10:04 +0800
commitd75d5dd5a34a02c7c1111d2a6f34c242d0485849 (patch)
tree089581cd36330e1b745acfc6f4deac64cf191b71
parent1f2dd0dacfa37642944d088fbb7dfbe961bd268b (diff)
downloadguix-d75d5dd5a34a02c7c1111d2a6f34c242d0485849.tar
guix-d75d5dd5a34a02c7c1111d2a6f34c242d0485849.tar.gz
gnu: Add fast-http.
* gnu/packages/lisp.scm (sbcl-fast-http, cl-fast-http): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lisp.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 319b161f39..c4cfede829 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -4518,3 +4518,43 @@ depending on content size.")
(define-public cl-smart-buffer
(sbcl-package->cl-source-package sbcl-smart-buffer))
+
+(define-public sbcl-fast-http
+ (let ((commit "f9e7597191bae380503e20724fd493a24d024935")
+ (revision "1"))
+ (package
+ (name "sbcl-fast-http")
+ (version (git-version "0.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fukamachi/fast-http")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qdmwv2zm0sizxdb8nnclgwl0nfjcbjaimbakavikijw7lr9b4jp"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; Tests fail with: Component FAST-HTTP-ASD::FAST-HTTP-TEST not found,
+ ;; required by #<SYSTEM "fast-http">. Why?
+ `(#:tests? #f))
+ (native-inputs
+ `(("sbcl-prove-asdf" ,sbcl-prove-asdf)
+ ("sbcl-prove" ,sbcl-prove)))
+ (inputs
+ `(("sbcl-alexandria" ,sbcl-alexandria)
+ ("sbcl-proc-parse" ,sbcl-proc-parse)
+ ("sbcl-xsubseq" ,sbcl-xsubseq)
+ ("sbcl-smart-buffer" ,sbcl-smart-buffer)
+ ("sbcl-utilities" ,sbcl-utilities)))
+ (home-page "https://github.com/fukamachi/fast-http")
+ (synopsis "HTTP request/response parser for Common Lisp")
+ (description
+ "@code{fast-http} is a HTTP request/response protocol parser for Common
+Lisp.")
+ ;; Author specified the MIT license
+ (license license:expat))))
+
+(define-public cl-fast-http
+ (sbcl-package->cl-source-package sbcl-fast-http))