aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 12:52:23 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 10:09:02 +0800
commit9945a170232167d680c6f3a3493be59b838ea630 (patch)
treee76bb000309e58ce855c65784fd714c12dcdd82b
parent610ee80a9c31e128e8569c16aef62202796cd755 (diff)
downloadguix-9945a170232167d680c6f3a3493be59b838ea630.tar
guix-9945a170232167d680c6f3a3493be59b838ea630.tar.gz
gnu: Add cl-base64.
* gnu/packages/lisp.scm (sbcl-cl-base64, cl-base64): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lisp.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d20f523477..194cb7bc2e 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -3996,3 +3996,38 @@ Rosenberg's CL packages.")
(define-public cl-kmrcl
(sbcl-package->cl-source-package sbcl-kmrcl))
+
+(define-public sbcl-cl-base64
+ (let ((version "3.3.3"))
+ (package
+ (name "sbcl-cl-base64")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://git.kpe.io/cl-base64.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1dw6j7n6gsd2qa0p0rbsjxj00acxx3i9ca1qkgl0liy8lpnwkypl"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; Tests fail with: :FORCE and :FORCE-NOT arguments not allowed
+ ;; in a nested call to ASDF/OPERATE:OPERATE unless identically
+ ;; to toplevel
+ '(#:tests? #f))
+ (inputs
+ `(("sbcl-ptester" ,sbcl-ptester)
+ ("sbcl-kmrcl" ,sbcl-kmrcl)))
+ (home-page "http://files.kpe.io/cl-base64/")
+ (synopsis
+ "Common Lisp package to encode and decode base64 with URI support")
+ (description
+ "This package provides highly optimized base64 encoding and decoding.
+Besides conversion to and from strings, integer conversions are supported.
+Encoding with Uniform Resource Identifiers is supported by using a modified
+encoding table that uses only URI-compatible characters.")
+ (license license:bsd-3))))
+
+(define-public cl-base64
+ (sbcl-package->cl-source-package sbcl-cl-base64))