aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 12:50:43 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 09:50:11 +0800
commit66c84d20c38025f315c180883930805ea5ce26ff (patch)
treeddcfbce0537307b6ef2e07c07db11b5254216075
parentd213718208fa767386a01ea66a86e391edf74331 (diff)
downloadguix-66c84d20c38025f315c180883930805ea5ce26ff.tar
guix-66c84d20c38025f315c180883930805ea5ce26ff.tar.gz
gnu: Add sbcl-md5.
* gnu/packages/lisp.scm (sbcl-md5, cl-md5): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lisp.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index b8fe98d498..3f77b6d268 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -3899,6 +3899,29 @@ process form data posted with HTTP POST method using enctype
(define-public cl-rfc2388
(sbcl-package->cl-source-package sbcl-rfc2388))
+(define-public sbcl-md5
+ (package
+ (name "sbcl-md5")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/pmai/md5/archive/release-" version ".tar.gz"))
+ (sha256
+ (base32 "19yl9n0pjdz5gw4qi711lka97xcd9f81ylg434hk7jwn9f2s6w11"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/pmai/md5")
+ (synopsis
+ "Common Lisp implementation of the MD5 Message-Digest Algorithm (RFC 1321)")
+ (description
+ "This package implements The MD5 Message-Digest Algorithm, as defined in
+RFC 1321 by R. Rivest, published April 1992.")
+ (license license:public-domain)))
+
+(define-public cl-md5
+ (sbcl-package->cl-source-package sbcl-md5))
+
(define-public sbcl-cl+ssl
(let ((commit "b81c1135cf5700e870ce2573d5035d249e491788")
(revision "1"))