aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 16:06:16 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 14:10:04 +0800
commit5ca7143fdccc9a77bc34b92d57fd98b377d1a360 (patch)
tree0b34e2f411a59961b9ffd38e8aa7148c8512d580
parent3f3dfd84595d7c8daeff5aa7cd9beac5bf7ac6d0 (diff)
downloadguix-5ca7143fdccc9a77bc34b92d57fd98b377d1a360.tar
guix-5ca7143fdccc9a77bc34b92d57fd98b377d1a360.tar.gz
gnu: Add http-body.
* gnu/packages/lisp.scm (sbcl-http-body, cl-http-body): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lisp.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 20860b48b5..1800cedfea 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -4733,3 +4733,41 @@ CCL.")
(define-public cl-jonathan
(sbcl-package->cl-source-package sbcl-jonathan))
+
+(define-public sbcl-http-body
+ (let ((commit "dd01dc4f5842e3d29728552e5163acce8386eb73")
+ (revision "1"))
+ (package
+ (name "sbcl-http-body")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fukamachi/http-body")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jd06snjvxcprhapgfq8sx0y5lrldkvhf206ix6d5a23dd6zcmr0"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; Tests fail with: Component HTTP-BODY-ASD::HTTP-BODY-TEST not
+ ;; found, required by #<SYSTEM "http-body">. Why?
+ `(#:tests? #f))
+ (native-inputs
+ `(("sbcl-prove-asdf" ,sbcl-prove-asdf)
+ ("sbcl-prove" ,sbcl-prove)))
+ (inputs
+ `(("sbcl-fast-http" ,sbcl-fast-http)
+ ("sbcl-jonathan" ,sbcl-jonathan)
+ ("sbcl-quri" ,sbcl-quri)))
+ (home-page "https://github.com/fukamachi/http-body")
+ (synopsis "HTTP POST data parser")
+ (description
+ "HTTP-Body parses HTTP POST data and returns POST parameters. It
+supports application/x-www-form-urlencoded, application/json, and
+multipart/form-data.")
+ (license license:bsd-2))))
+
+(define-public cl-http-body
+ (sbcl-package->cl-source-package sbcl-http-body))