aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-04 04:48:31 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-07 22:23:51 +0200
commit48b58245a7649500b1bca21e64ea8f6843b76078 (patch)
treec3da450d57b48fd4059ce73254af489f9678068c
parent96c822a3eae6f26cd28c7c14d176a8d3495ac240 (diff)
downloadguix-48b58245a7649500b1bca21e64ea8f6843b76078.tar
guix-48b58245a7649500b1bca21e64ea8f6843b76078.tar.gz
gnu: emacs-wgrep: Update to 2.3.0.
* gnu/packages/emacs-xyz.scm (emacs-wgrep): Update to 2.3.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 18 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e0b320a138..c9cbbaa154 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5268,28 +5268,26 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(license license:gpl3+)))
(define-public emacs-wgrep
- (let ((commit "414be70bd313e482cd9f0b70fd2daad4ee23497c"))
- ;; Late commit fixes compatibility issue with Emacs 26+.
- (package
- (name "emacs-wgrep")
- (version (git-version "2.1.10" "1" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mhayashi1120/Emacs-wgrep")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1sdhd587q3pg92lhiayph87azhalmf1gzrnsprkmqvnphv7mvks9"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/mhayashi1120/Emacs-wgrep")
- (synopsis "Edit a grep buffer and apply those changes to the files")
- (description
- "Emacs wgrep allows you to edit a grep buffer and apply those changes
+ (package
+ (name "emacs-wgrep")
+ (version "2.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mhayashi1120/Emacs-wgrep/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1cssqbg03fjb6xwf7idv1l3jjsh9r5r232ryi11czqlxfiv658bj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mhayashi1120/Emacs-wgrep")
+ (synopsis "Edit a grep buffer and apply those changes to the files")
+ (description
+ "Emacs wgrep allows you to edit a grep buffer and apply those changes
to the file buffer. Several backends are supported beside the classic grep:
ack, ag, helm and pt.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-helm
(package