aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Eisenmann <eisenmann@fn.de>2019-03-28 21:00:54 +0100
committerLudovic Courtès <ludo@gnu.org>2019-04-08 10:42:51 +0200
commit3df69aaf630efa5b5f7d56bb10239646792dda1d (patch)
tree3fe83838e811ef028e31dea34dd03126af7ec93d
parentb227457f6209695d8c612f9bbd60d76a1bfa766c (diff)
downloadguix-3df69aaf630efa5b5f7d56bb10239646792dda1d.tar
guix-3df69aaf630efa5b5f7d56bb10239646792dda1d.tar.gz
gnu: mpv: Set absolute path to 'youtube-dl'.
* gnu/packages/video.scm (mpv)[arguments]: Add phase 'patch-paths' to substitute in the absolute path to 'youtube-dl'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/video.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3a043fb34f..8aedc1c2f5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1326,6 +1326,14 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after
+ 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((ytdl (assoc-ref inputs "youtube-dl")))
+ (substitute* "player/lua/ytdl_hook.lua"
+ (("\"youtube-dl\",")
+ (string-append "\"" ytdl "/bin/youtube-dl\",")))
+ #t)))
(add-before
'configure 'setup-waf
(lambda* (#:key inputs #:allow-other-keys)