aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 15:58:09 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 14:10:04 +0800
commit135984ef153ea757ab06be34531d49839b6c692f (patch)
treeeeb129947c625252e9ae0e5c6a1d47050d74e70c
parent6ae60f04c1d83519b6db0c7f9b0f268ffd13f8dc (diff)
downloadguix-135984ef153ea757ab06be34531d49839b6c692f.tar
guix-135984ef153ea757ab06be34531d49839b6c692f.tar.gz
gnu: Add marshal.
* gnu/packages/lisp.scm (sbcl-marshal, cl-marshal): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lisp.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index abc7d8e3e6..99eb9cb830 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -4589,3 +4589,30 @@ memory.")
(define-public cl-static-vectors
(sbcl-package->cl-source-package sbcl-static-vectors))
+
+(define-public sbcl-marshal
+ (let ((commit "eff1b15f2b0af2f26f71ad6a4dd5c4beab9299ec")
+ (revision "1"))
+ (package
+ (name "sbcl-marshal")
+ (version (git-version "1.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wlbr/cl-marshal.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08qs6fhk38xpkkjkpcj92mxx0lgy4ygrbbzrmnivdx281syr0gwh"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/wlbr/cl-marshal")
+ (synopsis "Simple (de)serialization of Lisp datastructures")
+ (description
+ "Simple and fast marshalling of Lisp datastructures. Convert any object
+into a string representation, put it on a stream an revive it from there.
+Only minimal changes required to make your CLOS objects serializable.")
+ (license license:expat))))
+
+(define-public cl-marshal
+ (sbcl-package->cl-source-package sbcl-marshal))