aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 16:04:43 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 14:10:04 +0800
commit0fecb86cc45b70979e406ed6648877ef6c7b545b (patch)
tree579592eb76976f6f9075ba2e2e4e8c90ad283419
parent4a290afbba992a2ead29d8f9c819dd850e201577 (diff)
downloadguix-0fecb86cc45b70979e406ed6648877ef6c7b545b.tar
guix-0fecb86cc45b70979e406ed6648877ef6c7b545b.tar.gz
gnu: Add jonathan.
* gnu/packages/lisp.scm (sbcl-jonathan, cl-jonathan): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lisp.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 788c5c4dfc..87935adb2b 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -4693,3 +4693,43 @@ streams (though primarily the former, while wrapping the latter).")
(define-public cl-fast-io
(sbcl-package->cl-source-package sbcl-fast-io))
+
+(define-public sbcl-jonathan
+ (let ((commit "1f448b4f7ac8265e56e1c02b32ce383e65316300")
+ (revision "1"))
+ (package
+ (name "sbcl-jonathan")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Rudolph-Miller/jonathan.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14x4iwz3mbag5jzzzr4sb6ai0m9r4q4kyypbq32jmsk2dx1hi807"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; Tests fail with: Component JONATHAN-ASD::JONATHAN-TEST not found,
+ ;; required by #<SYSTEM "jonathan">. Why?
+ `(#:tests? #f))
+ (native-inputs
+ `(("sbcl-prove-asdf" ,sbcl-prove-asdf)
+ ("sbcl-prove" ,sbcl-prove)))
+ (inputs
+ `(("sbcl-syntax" ,sbcl-syntax)
+ ("sbcl-syntax-annot" ,sbcl-syntax-annot)
+ ("sbcl-fast-io" ,sbcl-fast-io)
+ ("sbcl-proc-parse" ,sbcl-proc-parse)
+ ("sbcl-cl-ppcre" ,sbcl-cl-ppcre)))
+ (home-page "http://rudolph-miller.github.io/jonathan/overview.html")
+ (synopsis "JSON encoder and decoder")
+ (description
+ "High performance JSON encoder and decoder. Currently support: SBCL,
+CCL.")
+ ;; Author specifies the MIT license
+ (license license:expat))))
+
+(define-public cl-jonathan
+ (sbcl-package->cl-source-package sbcl-jonathan))