aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-06-22 15:13:58 -0400
committerKei Kebreau <kei@openmailbox.org>2017-06-22 17:00:00 -0400
commitfa56c7733d88d3821c92ea1c48d2681bd99aeba4 (patch)
tree8eff40bfa7deb31819cf12f6141c42db99d9adcf
parent005c4ef85c6291d2dca281d2218cc0af60c880d3 (diff)
downloadguix-fa56c7733d88d3821c92ea1c48d2681bd99aeba4.tar
guix-fa56c7733d88d3821c92ea1c48d2681bd99aeba4.tar.gz
gnu: Add python-uniseg.
* gnu/packages/python.scm (python-uniseg, python2-uniseg): New variables.
-rw-r--r--gnu/packages/python.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a63006a043..3c3b4056d4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -987,6 +988,42 @@ Python 3 support.")
(define-public python2-setuptools
(package-with-python2 python-setuptools))
+(define-public python-uniseg
+ (package
+ (name "python-uniseg")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/emptypage/uniseg-python/"
+ "get/rel-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1df4gddnj2a0v8z35wb2ra5vvh1f1qyxs8fgd25c8g64031mna6x"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; The test suite requires network access.
+ (home-page
+ "https://bitbucket.org/emptypage/uniseg-python")
+ (synopsis
+ "Python library to determine Unicode text segmentations")
+ (description
+ "Uniseg is a Python package used to determine Unicode text segmentations.
+Supported segmentations include:
+@enumerate
+@item @dfn{Code point} (any value in the Unicode codespace)
+@item @dfn{Grapheme cluster} (user-perceived character made of a single or
+multiple Unicode code points, e.g. \"G\" + acute-accent)
+@item Word break
+@item Sentence break
+@item Line break
+@end enumerate")
+ (license license:expat)))
+
+(define-public python2-uniseg
+ (package-with-python2 python-uniseg))
+
;;; Pycrypto is abandoned upstream:
;;;
;;; https://github.com/dlitz/pycrypto/issues/173