aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-05-20 09:07:27 +0000
committerKei Kebreau <kei@openmailbox.org>2017-06-22 10:45:37 -0400
commite81fd90e2f8a38248b4b0c6b883305528acc9a9e (patch)
tree5897b10a9d6e2c50805d17848ea995eb3301b38c
parent202afee2dad13aaaaf8dc88effe36a22f7ba671a (diff)
downloadguix-e81fd90e2f8a38248b4b0c6b883305528acc9a9e.tar
guix-e81fd90e2f8a38248b4b0c6b883305528acc9a9e.tar.gz
gnu: surfraw: Fix broken symlinks in manpages.
* gnu/packages/web.scm (surfraw)[arguments]: Add new 'compress-elvi.1sr' phase. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
-rw-r--r--gnu/packages/web.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3a6e20d1bd..3625a1034e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2016, 2017 ng0 <ng0@no-reply.pragmatique.xyz>
;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
@@ -4259,6 +4259,17 @@ handling many of the web standards in use today.")
(base32
"1fy4ph5h9kp0jzj1m6pfylxnnmgdk0mmdppw76z9jhna4jndk5xa"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'compress-elvi.1sr
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The manpages of the elvis are symlinks to elvi.1sr.gz
+ ;; but elvi.1sr does not get compressed by our manpage phase.
+ (let* ((out (assoc-ref %outputs "out"))
+ (man (string-append out "/share/man/man1")))
+ (with-directory-excursion man
+ (zero? (system* "gzip" "elvi.1sr")))))))))
(inputs
`(("perl" ,perl)
("perl-www-opensearch" ,perl-www-opensearch)