aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-06-16 13:36:58 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-20 22:33:09 +0200
commitb3ebd24162f69e55b9847d9a160d255737e39d68 (patch)
tree913d5c0ab7ed6f6a1fb10abb130ac6f12a10b384
parent3f56740d7231b98d7b0100233d965d82e17cfede (diff)
downloadguix-b3ebd24162f69e55b9847d9a160d255737e39d68.tar
guix-b3ebd24162f69e55b9847d9a160d255737e39d68.tar.gz
gnu: Add wine64.
* gnu/packages/wine.scm (wine64): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/wine.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 72700ef3df..517b9f236e 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -147,3 +147,23 @@ integrate Windows applications into your desktop.")
;; It really only supports IA32, but building on x86_64 will have the same
;; effect as building on i686 anyway.
(supported-systems '("i686-linux" "x86_64-linux"))))
+
+(define-public wine64
+ (package
+ (inherit wine)
+ (name "wine64")
+ (arguments
+ `(#:configure-flags
+ (list "--enable-win64"
+ (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib64"))
+ ,@(strip-keyword-arguments '(#:configure-flags #:system)
+ (package-arguments wine))))
+ (synopsis "Implementation of the Windows API (64-bit version)")
+ (description
+ "Wine (originally an acronym for \"Wine Is Not an Emulator\") is a
+compatibility layer capable of running Windows applications. Instead of
+simulating internal Windows logic like a virtual machine or emulator, Wine
+translates Windows API calls into POSIX calls on-the-fly, eliminating the
+performance and memory penalties of other methods and allowing you to cleanly
+integrate Windows applications into your desktop. This is the 64-bit version.")
+ (supported-systems '("x86_64-linux"))))