aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-06-22 22:33:28 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-23 14:16:44 +0200
commit7efd98be87a91f6d1fba20eb119e13d6390b569d (patch)
tree7dec1f503e81e1496907670d1641c8ae93b8a34b
parentf817b4d9039e9a8d4ac0b4034f79a60f530296de (diff)
downloadguix-7efd98be87a91f6d1fba20eb119e13d6390b569d.tar
guix-7efd98be87a91f6d1fba20eb119e13d6390b569d.tar.gz
gnu: Add python-rencode.
* gnu/packages/python.scm (python-rencode): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d9e004ecbe..6150a8798f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15472,3 +15472,31 @@ functionality like full case-folding for case-insensitive matches in Unicode.")
related APIs. The binding is created using the standard @code{ctypes}
library.")
(license license:bsd-3)))
+
+(define-public python-rencode
+ (package
+ (name "python-rencode")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rencode" version))
+ (sha256
+ (base32
+ "08if5yax1xn5yfp8p3765ccjmfcv9di7i4m5jckgnwvdsgznwkbj"))))
+ (build-system python-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("python-cython", python-cython)))
+ (home-page "https://github.com/aresch/rencode")
+ (synopsis "Serialization of heterogeneous data structures")
+ (description
+ "The @code{rencode} module is a data structure serialization library,
+similar to @code{bencode} from the BitTorrent project. For complex,
+heterogeneous data structures with many small elements, r-encoding stake up
+significantly less space than b-encodings. This version of rencode is a
+complete rewrite in Cython to attempt to increase the performance over the
+pure Python module.")
+ (license license:bsd-3)))
+
+(define-public python2-rencode
+ (package-with-python2 python-rencode))