aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-06-19 13:34:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-06-21 21:58:37 +0200
commit636437ec5086ca6525fac5f236d4b466958d5970 (patch)
treeaabd0265ea25ed2c08f7f98f4413d05624bf8e6e
parent3b66438983cb6ca33b637e6db495c02ff5a8361a (diff)
downloadguix-636437ec5086ca6525fac5f236d4b466958d5970.tar
guix-636437ec5086ca6525fac5f236d4b466958d5970.tar.gz
gnu: Remove unused python-flake8-2.2.4.
* gnu/packages/python.scm (python-flake8-2.2.4): Remove variable.
-rw-r--r--gnu/packages/python.scm34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 67a52bc9db..de42d3d56e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6521,40 +6521,6 @@ complexity of Python source code.")
(define-public python2-flake8
(package-with-python2 python-flake8))
-;; This will only be needed by the python-hacking package and will not be
-;; necessary once python-hacking > 0.10.2 is released.
-(define-public python-flake8-2.2.4
- (package (inherit python-flake8)
- (propagated-inputs
- `(("python-pep8" ,python-pep8-1.5.7)
- ("python-pyflakes" ,python-pyflakes-0.8.1)
- ("python-mccabe" ,python-mccabe-0.2.1)))
- (native-inputs
- `(("python-mock" ,python-mock)
- ("python-nose" ,python-nose)))
- (version "2.2.4")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "flake8" version))
- (sha256
- (base32
- "1r9wsry4va45h1rck5hxd3vzsg2q3y6lnl6pym1bxvz8ry19jwx8"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove pre-compiled .pyc files from source.
- (for-each delete-file-recursively
- (find-files "." "__pycache__" #:directories? #t))
- (for-each delete-file (find-files "." "\\.pyc$"))
- #t))))
- (arguments
- ;; XXX Fails with Python 3.5.
- '(#:tests? #f))))
-
-(define-public python2-flake8-2.2.4
- (package-with-python2 python-flake8-2.2.4))
-
(define-public python-flake8-polyfill
(package
(name "python-flake8-polyfill")