aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-06-19 13:29:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-06-21 21:58:37 +0200
commit3b66438983cb6ca33b637e6db495c02ff5a8361a (patch)
treed687350411cef460b7f53e8e1db8e993efd63b57
parent5150d8b4b4b993af1d2d2527c69ee1bcc74a84a3 (diff)
downloadguix-3b66438983cb6ca33b637e6db495c02ff5a8361a.tar
guix-3b66438983cb6ca33b637e6db495c02ff5a8361a.tar.gz
gnu: python-hacking: Update to 0.13.0.
* gnu/packages/openstack.scm (python-hacking): Update to 0.13.0. [arguments]: Re-enable tests. [propagated-inputs]: Use latest python-flake8. [native-inputs]: Add python-eventlet, python-mock, python-reno, and python-testrepository for tests.
-rw-r--r--gnu/packages/openstack.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 23859b85c2..86d1ce9978 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -113,32 +113,33 @@ manner.")
(define-public python-hacking
(package
(name "python-hacking")
- (version "0.10.2")
+ (version "0.13.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "hacking" version))
(sha256
(base32
- "1a310k3dv04jg7zvmk37h2ql7y9kf4hvdxb74bjlwdxgmy6h4wap"))))
+ "1s1wq2sds6fjp8rwz31vkp33kjl9nyk5y2g2pri8shic75dr00h4"))))
(build-system python-build-system)
- (arguments
- ;; TODO: Requires unpackaged 'eventlet'.
- '(#:tests? #f))
(propagated-inputs
- `(("python-flake8-2.2.4" ,python-flake8-2.2.4)
- ("python-mccabe-0.2.1" ,python-mccabe-0.2.1)
- ("python-pbr" ,python-pbr)
- ("python-pep8-1.5.7" ,python-pep8-1.5.7)
- ("python-pyflakes-0.8.1" ,python-pyflakes-0.8.1)
- ("python-six" ,python-six)))
+ `(("python-flake8" ,python-flake8)
+ ("python-mccabe-0.2.1" ,python-mccabe-0.2.1)
+ ("python-pbr" ,python-pbr)
+ ("python-pep8-1.5.7" ,python-pep8-1.5.7)
+ ("python-pyflakes-0.8.1" ,python-pyflakes-0.8.1)
+ ("python-six" ,python-six)))
(native-inputs
- `(;; Tests
- ("python-testscenarios" ,python-testscenarios)))
+ `( ;; Tests
+ ("python-eventlet" ,python-eventlet)
+ ("python-mock" ,python-mock)
+ ("python-reno" ,python-reno)
+ ("python-testrepository" ,python-testrepository)
+ ("python-testscenarios" ,python-testscenarios)))
(home-page "https://github.com/openstack-dev/hacking")
(synopsis "OpenStack hacking guideline enforcement")
(description
- "Python-hacking is a set of flake8 plugins that test and enforce the
+ "Python-hacking is a set of flake8 plugins that test and enforce the
@uref{http://docs.openstack.org/developer/hacking/, OpenStack style
guidelines}.")
(license asl2.0)))