aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornee <nee.git@cock.li>2017-06-10 19:12:10 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-22 23:07:09 +0200
commit3116c8b5e05d5fd120a2da1fbac51acafc13dfb0 (patch)
treeb173fd8694554769d7be81e0344b821fba7773b6
parentcde208da318845a69f1ea97679700191926f71aa (diff)
downloadguix-3116c8b5e05d5fd120a2da1fbac51acafc13dfb0.tar
guix-3116c8b5e05d5fd120a2da1fbac51acafc13dfb0.tar.gz
gnu: Add ddate.
* gnu/packages/linux.scm (ddate): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 03cf8ed2a4..9ba35a0a1e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017 nee <nee-git@hidamari.blue>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -605,6 +606,27 @@ block devices, UUIDs, TTYs, and many other tools.")
(license (list license:gpl3+ license:gpl2+ license:gpl2 license:lgpl2.0+
license:bsd-4 license:public-domain))))
+(define-public ddate
+ (package
+ (name "ddate")
+ (version "0.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/bo0ts/ddate/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1bbqqq8mswj4bp9083gxjaky5ysfznax4cynsqwmy125z053yg6m"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f))
+ (home-page "https://github.com/bo0ts/ddate")
+ (synopsis "PERPETUAL DATE CONVERTER FROM GREGORIAN TO POEE CALENDAR")
+ (description
+ "ddate displays the Discordian date and holidays of a given date.
+The Discordian calendar was made popular by the \"Illuminatus!\" trilogy
+by Robert Shea and Robert Anton Wilson.")
+ (license license:public-domain)))
+
(define-public procps
(package
(name "procps")