aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-04 11:41:07 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-04 15:40:32 +0200
commitabdb0210bd738fafd744c229c28e92d9898fae6f (patch)
treeac89b6873d00f0c79705113abb23235b446b02d5
parent3d25bc8ae4738b0420fca86fead8203a6d24710d (diff)
downloadguix-abdb0210bd738fafd744c229c28e92d9898fae6f.tar
guix-abdb0210bd738fafd744c229c28e92d9898fae6f.tar.gz
gnu: bcachefs-tools: Prepare for cross-compilation.
* gnu/packages/file-systems.scm (bcachefs-tools)[arguments]: Use CC-FOR-TARGET and PKG-CONFIG-FOR-TARGET.
-rw-r--r--gnu/packages/file-systems.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 46d9227ace..c3051b835e 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -360,7 +360,8 @@ from a mounted file system.")
(list ,(string-append "VERSION=" version) ; bogus vX.Y-nogit otherwise
(string-append "PREFIX=" (assoc-ref %outputs "out"))
"INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
- "CC=gcc"
+ ,(string-append "CC=" (cc-for-target))
+ ,(string-append "PKG_CONFIG=" (pkg-config-for-target))
"PYTEST=pytest")
#:phases
(modify-phases %standard-phases