aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-04 21:33:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-04 22:48:34 +0200
commit763feb97cd04a709e5e0dcbeb7e501e9b6c34f0d (patch)
tree75334ecc0af4a088a7994a850297c3704492c190
parent58805da44dac6b180245edd8a6419343f64d221c (diff)
downloadguix-763feb97cd04a709e5e0dcbeb7e501e9b6c34f0d.tar
guix-763feb97cd04a709e5e0dcbeb7e501e9b6c34f0d.tar.gz
gnu: powertop: Update to 2.14.
* gnu/packages/linux.scm (powertop): Update to 2.14. [source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Add required #:configure-flags. [native-inputs]: Add autoconf, automake, gettext, and libtool.
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 86f5394bab..135de525bb 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2821,17 +2821,21 @@ devices. It replaces @code{iwconfig}, which is deprecated.")
(define-public powertop
(package
(name "powertop")
- (version "2.13")
+ (version "2.14")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://01.org/sites/default/files/downloads/"
- "powertop-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fenrus75/powertop")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0y1ixw8v17fdb1ima0zshrd0rh4zxdh10r93nrrvq6d4lhn9jpx6"))))
+ (base32 "1zkr2y5nb1nr22nq8a3zli87iyfasfq6489p7h1k428pv8k45w4f"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ '(#:configure-flags
+ (list "LDFLAGS=-pthread")
+ #:phases
(modify-phases %standard-phases
;; TODO: Patch some hardcoded "wlan0" in calibrate/calibrate.cpp to
;; allow calibrating the network interface in Guix System.
@@ -2856,7 +2860,11 @@ devices. It replaces @code{iwconfig}, which is deprecated.")
("pciutils" ,pciutils)
("zlib" ,zlib)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(home-page "https://01.org/powertop/")
(synopsis "Analyze power consumption on Intel-based laptops")
(description