aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-04-18 15:09:01 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-04-18 15:09:33 +0200
commit8fc446088974e749d3e71f888a76fefc4898f8aa (patch)
tree7e8170a6101bc9a603f169bfd3032715ebfb3769
parent0cfe02cf55baf8ef1395bc8f108672159355f606 (diff)
downloadguix-8fc446088974e749d3e71f888a76fefc4898f8aa.tar
guix-8fc446088974e749d3e71f888a76fefc4898f8aa.tar.gz
gnu: python-lfdfiles: Fix build.
* gnu/packages/python-xyz.scm (python-lfdfiles) [source]: Remove pre-generated C files. [native-inputs]: Add python-cython. [arguments]: Disable tests.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 258f337f82..0e12f75357 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6221,12 +6221,21 @@ numpy arrays to TIFF, BigTIFF, and ImageJ hyperstack compatible files.")
(uri (pypi-uri "lfdfiles" version))
(sha256
(base32
- "12fxm4v805dgjrih7x6jnl1wd7y7jw1rkhjs3d4am8s6qk1cbar2"))))
+ "12fxm4v805dgjrih7x6jnl1wd7y7jw1rkhjs3d4am8s6qk1cbar2"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete pre-generated Cython files.
+ (for-each delete-file (find-files "lfdfiles" "_.*\\.c$"))
+ #t))))
(build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; No tests exist, despite a test dependency on pytest.
(propagated-inputs
`(("python-click" ,python-click)
("python-numpy" ,python-numpy)
("python-tifffile" ,python-tifffile)))
+ (native-inputs `(("python-cython" ,python-cython)))
(home-page "https://www.lfd.uci.edu/~gohlke/")
(synopsis "Work with LFD data files")
(description